summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/drivers/net/pcap/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/seastar/dpdk/drivers/net/pcap/meson.build')
-rw-r--r--src/seastar/dpdk/drivers/net/pcap/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/seastar/dpdk/drivers/net/pcap/meson.build b/src/seastar/dpdk/drivers/net/pcap/meson.build
new file mode 100644
index 000000000..2c2fd11e4
--- /dev/null
+++ b/src/seastar/dpdk/drivers/net/pcap/meson.build
@@ -0,0 +1,20 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+pcap_dep = dependency('pcap', required: false)
+if pcap_dep.found()
+ build = true
+else
+ # pcap got a pkg-config file only in 1.9.0 and before that meson uses
+ # an internal pcap-config finder, which is not compatible with
+ # cross-compilation, so try to fallback to find_library
+ pcap_dep = cc.find_library('pcap', required: false)
+ if pcap_dep.found() and cc.has_header('pcap.h', dependencies: pcap_dep)
+ build = true
+ pkgconfig_extra_libs += '-lpcap'
+ else
+ build = false
+ endif
+endif
+sources = files('rte_eth_pcap.c')
+ext_deps += pcap_dep