summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/examples/performance-thread/l3fwd-thread/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/seastar/dpdk/examples/performance-thread/l3fwd-thread/Makefile')
-rw-r--r--src/seastar/dpdk/examples/performance-thread/l3fwd-thread/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/seastar/dpdk/examples/performance-thread/l3fwd-thread/Makefile b/src/seastar/dpdk/examples/performance-thread/l3fwd-thread/Makefile
new file mode 100644
index 000000000..1a1c95829
--- /dev/null
+++ b/src/seastar/dpdk/examples/performance-thread/l3fwd-thread/Makefile
@@ -0,0 +1,29 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2010-2015 Intel Corporation
+
+ifeq ($(RTE_SDK),)
+$(error "Please define RTE_SDK environment variable")
+endif
+
+# Default target, detect a build directory, by looking for a path with a .config
+RTE_TARGET ?= $(notdir $(abspath $(dir $(firstword $(wildcard $(RTE_SDK)/*/.config)))))
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+# binary name
+APP = l3fwd-thread
+
+# all source are stored in SRCS-y
+SRCS-y := main.c
+
+include $(RTE_SDK)/examples/performance-thread/common/common.mk
+
+CFLAGS += -O3 -g $(USER_FLAGS) $(INCLUDES) $(WERROR_FLAGS)
+
+# workaround for a gcc bug with noreturn attribute
+# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=12603
+#ifeq ($(CONFIG_RTE_TOOLCHAIN_GCC),y)
+CFLAGS_main.o += -Wno-return-type
+#endif
+
+include $(RTE_SDK)/mk/rte.extapp.mk