summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/examples/quota_watermark/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/seastar/dpdk/examples/quota_watermark/Makefile')
-rw-r--r--src/seastar/dpdk/examples/quota_watermark/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/seastar/dpdk/examples/quota_watermark/Makefile b/src/seastar/dpdk/examples/quota_watermark/Makefile
new file mode 100644
index 000000000..8ef053198
--- /dev/null
+++ b/src/seastar/dpdk/examples/quota_watermark/Makefile
@@ -0,0 +1,16 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2010-2014 Intel Corporation
+
+ifeq ($(RTE_SDK),)
+$(error "Please define RTE_SDK environment variable")
+endif
+
+# Default target, detect a build directory, by looking for a path with a .config
+RTE_TARGET ?= $(notdir $(abspath $(dir $(firstword $(wildcard $(RTE_SDK)/*/.config)))))
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+DIRS-$(CONFIG_RTE_EXEC_ENV_LINUX) += qw
+DIRS-$(CONFIG_RTE_EXEC_ENV_LINUX) += qwctl
+
+include $(RTE_SDK)/mk/rte.extsubdir.mk