summaryrefslogtreecommitdiffstats
path: root/src/seastar/dpdk/lib/librte_cryptodev/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/seastar/dpdk/lib/librte_cryptodev/meson.build')
-rw-r--r--src/seastar/dpdk/lib/librte_cryptodev/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/seastar/dpdk/lib/librte_cryptodev/meson.build b/src/seastar/dpdk/lib/librte_cryptodev/meson.build
new file mode 100644
index 000000000..9e009d466
--- /dev/null
+++ b/src/seastar/dpdk/lib/librte_cryptodev/meson.build
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017-2019 Intel Corporation
+
+version = 7
+allow_experimental_apis = true
+sources = files('rte_cryptodev.c', 'rte_cryptodev_pmd.c')
+headers = files('rte_cryptodev.h',
+ 'rte_cryptodev_pmd.h',
+ 'rte_crypto.h',
+ 'rte_crypto_sym.h',
+ 'rte_crypto_asym.h')
+deps += ['kvargs', 'mbuf']