summaryrefslogtreecommitdiffstats
path: root/src/spdk/doc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/doc/Makefile')
-rw-r--r--src/spdk/doc/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/spdk/doc/Makefile b/src/spdk/doc/Makefile
new file mode 100644
index 000000000..ec3f396d9
--- /dev/null
+++ b/src/spdk/doc/Makefile
@@ -0,0 +1,23 @@
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/..)
+include $(SPDK_ROOT_DIR)/mk/spdk.common.mk
+
+all: doc
+ @:
+
+.PHONY: all doc clean
+
+doc: output
+
+changelog.md: ../CHANGELOG.md
+ $(Q)sed -e 's/^# Changelog/# Changelog {#changelog}/' \
+ -e 's/^##/#/' \
+ -e 's/^# \(\(v..\...\):.*\)/# \1 {#changelog-\2}/' \
+ -e '/# v..\...:/s/\./-/2' \
+ < $< > $@
+
+output: Doxyfile changelog.md $(wildcard *.md) $(wildcard ../include/spdk/*.h)
+ $(Q)rm -rf $@
+ $(Q)doxygen Doxyfile
+
+clean:
+ $(Q)rm -rf output changelog.md