summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/lib/librte_ethdev/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/dpdk/lib/librte_ethdev/Makefile')
-rw-r--r--src/spdk/dpdk/lib/librte_ethdev/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/spdk/dpdk/lib/librte_ethdev/Makefile b/src/spdk/dpdk/lib/librte_ethdev/Makefile
new file mode 100644
index 000000000..47747150b
--- /dev/null
+++ b/src/spdk/dpdk/lib/librte_ethdev/Makefile
@@ -0,0 +1,46 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2010-2017 Intel Corporation
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+#
+# library name
+#
+LIB = librte_ethdev.a
+
+CFLAGS += -O3
+CFLAGS += $(WERROR_FLAGS)
+LDLIBS += -lrte_net -lrte_eal -lrte_mempool -lrte_ring
+LDLIBS += -lrte_mbuf -lrte_kvargs -lrte_meter -lrte_telemetry
+
+EXPORT_MAP := rte_ethdev_version.map
+
+SRCS-y += ethdev_private.c
+SRCS-y += rte_ethdev.c
+SRCS-y += rte_class_eth.c
+SRCS-y += rte_flow.c
+SRCS-y += rte_tm.c
+SRCS-y += rte_mtr.c
+SRCS-y += ethdev_profile.c
+SRCS-y += ethdev_trace_points.c
+
+#
+# Export include files
+#
+SYMLINK-y-include += rte_ethdev.h
+SYMLINK-y-include += rte_ethdev_driver.h
+SYMLINK-y-include += rte_ethdev_core.h
+SYMLINK-y-include += rte_ethdev_pci.h
+SYMLINK-y-include += rte_ethdev_trace.h
+SYMLINK-y-include += rte_ethdev_trace_fp.h
+SYMLINK-y-include += rte_ethdev_vdev.h
+SYMLINK-y-include += rte_eth_ctrl.h
+SYMLINK-y-include += rte_dev_info.h
+SYMLINK-y-include += rte_flow.h
+SYMLINK-y-include += rte_flow_driver.h
+SYMLINK-y-include += rte_tm.h
+SYMLINK-y-include += rte_tm_driver.h
+SYMLINK-y-include += rte_mtr.h
+SYMLINK-y-include += rte_mtr_driver.h
+
+include $(RTE_SDK)/mk/rte.lib.mk