summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/lib/librte_latencystats/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/dpdk/lib/librte_latencystats/Makefile')
-rw-r--r--src/spdk/dpdk/lib/librte_latencystats/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/spdk/dpdk/lib/librte_latencystats/Makefile b/src/spdk/dpdk/lib/librte_latencystats/Makefile
new file mode 100644
index 000000000..b19e0b178
--- /dev/null
+++ b/src/spdk/dpdk/lib/librte_latencystats/Makefile
@@ -0,0 +1,22 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+# library name
+LIB = librte_latencystats.a
+
+CFLAGS += $(WERROR_FLAGS) -I$(SRCDIR) -O3
+LDLIBS += -lm
+LDLIBS += -lpthread
+LDLIBS += -lrte_eal -lrte_metrics -lrte_ethdev -lrte_mbuf
+
+EXPORT_MAP := rte_latencystats_version.map
+
+# all source are stored in SRCS-y
+SRCS-$(CONFIG_RTE_LIBRTE_LATENCY_STATS) := rte_latencystats.c
+
+# install this header file
+SYMLINK-$(CONFIG_RTE_LIBRTE_LATENCY_STATS)-include := rte_latencystats.h
+
+include $(RTE_SDK)/mk/rte.lib.mk