summaryrefslogtreecommitdiffstats
path: root/src/test/cls_queue/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/cls_queue/CMakeLists.txt')
-rw-r--r--src/test/cls_queue/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/test/cls_queue/CMakeLists.txt b/src/test/cls_queue/CMakeLists.txt
new file mode 100644
index 000000000..d600537c9
--- /dev/null
+++ b/src/test/cls_queue/CMakeLists.txt
@@ -0,0 +1,17 @@
+add_executable(ceph_test_cls_queue
+ test_cls_queue.cc
+)
+target_link_libraries(ceph_test_cls_queue
+ cls_queue_client
+ librados
+ global
+ ${UNITTEST_LIBS}
+ ${EXTRALIBS}
+ ${BLKID_LIBRARIES}
+ ${CMAKE_DL_LIBS}
+ radostest-cxx)
+
+install(TARGETS
+ ceph_test_cls_queue
+ DESTINATION ${CMAKE_INSTALL_BINDIR})
+