summaryrefslogtreecommitdiffstats
path: root/src/test/lazy-omap-stats/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/lazy-omap-stats/CMakeLists.txt')
-rw-r--r--src/test/lazy-omap-stats/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/test/lazy-omap-stats/CMakeLists.txt b/src/test/lazy-omap-stats/CMakeLists.txt
new file mode 100644
index 000000000..636d24c4e
--- /dev/null
+++ b/src/test/lazy-omap-stats/CMakeLists.txt
@@ -0,0 +1,10 @@
+# Lazy omap stat collection tests
+
+add_executable(ceph_test_lazy_omap_stats
+ main.cc
+ lazy_omap_stats_test.cc)
+target_link_libraries(ceph_test_lazy_omap_stats
+ librados Boost::system Boost::filesystem ${UNITTEST_LIBS})
+install(TARGETS
+ ceph_test_lazy_omap_stats
+ DESTINATION ${CMAKE_INSTALL_BINDIR})