summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:21:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:21:58 +0000
commit9e1bf39a3dc5e9b967a8c898f3889e470ba9ae5c (patch)
tree7cdd841773964692023fa55f18cca39ef94261d0 /Makefile
parentInitial commit. (diff)
downloaddebootstrap-9e1bf39a3dc5e9b967a8c898f3889e470ba9ae5c.tar.xz
debootstrap-9e1bf39a3dc5e9b967a8c898f3889e470ba9ae5c.zip
Adding upstream version 1.0.128+nmu2+deb12u1.upstream/1.0.128+nmu2+deb12u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..8516803
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,18 @@
+# avoid dpkg-dev dependency; fish out the version with sed
+VERSION := $(shell sed 's/.*(\(.*\)).*/\1/; q' debian/changelog)
+
+all:
+
+clean:
+
+DSDIR=$(DESTDIR)/usr/share/debootstrap
+install:
+ mkdir -p $(DSDIR)/scripts
+ mkdir -p $(DESTDIR)/usr/sbin
+
+ cp -a scripts/* $(DSDIR)/scripts/
+ install -o root -g root -m 0644 functions $(DSDIR)/
+
+ sed 's/@VERSION@/$(VERSION)/g' debootstrap >$(DESTDIR)/usr/sbin/debootstrap
+ chown root:root $(DESTDIR)/usr/sbin/debootstrap
+ chmod 0755 $(DESTDIR)/usr/sbin/debootstrap