summaryrefslogtreecommitdiffstats
path: root/scripts/t/mk/buildflags.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /scripts/t/mk/buildflags.mk
parentInitial commit. (diff)
downloaddpkg-upstream.tar.xz
dpkg-upstream.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripts/t/mk/buildflags.mk')
-rw-r--r--scripts/t/mk/buildflags.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/scripts/t/mk/buildflags.mk b/scripts/t/mk/buildflags.mk
new file mode 100644
index 0000000..542bced
--- /dev/null
+++ b/scripts/t/mk/buildflags.mk
@@ -0,0 +1,16 @@
+DEB_CPPFLAGS_MAINT_APPEND = -DTEST_MK=test
+
+include $(srcdir)/mk/buildflags.mk
+
+test:
+ test "$(ASFLAGS)" = "$(TEST_ASFLAGS)"
+ test "$(CFLAGS)" = "$(TEST_CFLAGS)"
+ test "$(CPPFLAGS)" = "$(TEST_CPPFLAGS) -DTEST_MK=test"
+ test "$(CXXFLAGS)" = "$(TEST_CXXFLAGS)"
+ test "$(DFLAGS)" = "$(TEST_DFLAGS)"
+ test "$(FCFLAGS)" = "$(TEST_FCFLAGS)"
+ test "$(FFLAGS)" = "$(TEST_FFLAGS)"
+ test "$(GCJFLAGS)" = "$(TEST_GCJFLAGS)"
+ test "$(LDFLAGS)" = "$(TEST_LDFLAGS)"
+ test "$(OBJCFLAGS)" = "$(TEST_OBJCFLAGS)"
+ test "$(OBJCXXFLAGS)" = "$(TEST_OBJCXXFLAGS)"