summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-forceask/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-conffile-forceask/Makefile
parentInitial commit. (diff)
downloaddpkg-upstream.tar.xz
dpkg-upstream.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-conffile-forceask/Makefile')
-rw-r--r--tests/t-conffile-forceask/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/t-conffile-forceask/Makefile b/tests/t-conffile-forceask/Makefile
new file mode 100644
index 0000000..c40e2fe
--- /dev/null
+++ b/tests/t-conffile-forceask/Makefile
@@ -0,0 +1,16 @@
+TESTS_DEB := pkg-conff-forceask-0 pkg-conff-forceask-1
+
+include ../Test.mk
+
+test-case:
+
+ # Test that we get the new conffile after a modified one.
+ $(DPKG_INSTALL) pkg-conff-forceask-0.deb
+ $(BEROOT) cp mod-conffile "$(DPKG_INSTDIR)/test-conffile"
+ $(DPKG_INSTALL) --force-confask --force-confnew pkg-conff-forceask-1.deb
+ cmp mod-conffile "$(DPKG_INSTDIR)/test-conffile.dpkg-old"
+ cmp ref-conffile "$(DPKG_INSTDIR)/test-conffile"
+ $(DPKG_PURGE) pkg-conff-forceask
+
+test-clean:
+ $(DPKG_PURGE) pkg-conff-forceask