summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-replaces-diverted
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-conffile-replaces-diverted
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-conffile-replaces-diverted')
-rw-r--r--tests/t-conffile-replaces-diverted/Makefile18
-rw-r--r--tests/t-conffile-replaces-diverted/pkg-conff-0/DEBIAN/conffiles1
-rw-r--r--tests/t-conffile-replaces-diverted/pkg-conff-0/DEBIAN/control7
-rw-r--r--tests/t-conffile-replaces-diverted/pkg-conff-0/test/conffile1
-rw-r--r--tests/t-conffile-replaces-diverted/pkg-conff-1/DEBIAN/control7
-rw-r--r--tests/t-conffile-replaces-diverted/pkg-conff-move/DEBIAN/conffiles1
-rw-r--r--tests/t-conffile-replaces-diverted/pkg-conff-move/DEBIAN/control8
-rw-r--r--tests/t-conffile-replaces-diverted/pkg-conff-move/test/conffile1
8 files changed, 44 insertions, 0 deletions
diff --git a/tests/t-conffile-replaces-diverted/Makefile b/tests/t-conffile-replaces-diverted/Makefile
new file mode 100644
index 0000000..5e9b176
--- /dev/null
+++ b/tests/t-conffile-replaces-diverted/Makefile
@@ -0,0 +1,18 @@
+TESTS_DEB := pkg-conff-0 pkg-conff-1 pkg-conff-move
+
+include ../Test.mk
+
+DPKG_DIVERT_OPTIONS += --local --rename --divert /test/conffile.moved
+
+test-case:
+ $(DPKG_INSTALL) pkg-conff-0.deb
+ $(DPKG_DIVERT_ADD) /test/conffile
+ test -f '$(DPKG_INSTDIR)/test/conffile.moved'
+ # Test if the other package can takeover a diverted conffile w/o error.
+ $(DPKG_INSTALL) pkg-conff-1.deb
+ $(DPKG_INSTALL) pkg-conff-move.deb
+
+test-clean:
+ $(DPKG_DIVERT_DEL) /test/conffile
+ $(DPKG_PURGE) pkg-conff
+ $(DPKG_PURGE) pkg-conff-move
diff --git a/tests/t-conffile-replaces-diverted/pkg-conff-0/DEBIAN/conffiles b/tests/t-conffile-replaces-diverted/pkg-conff-0/DEBIAN/conffiles
new file mode 100644
index 0000000..e2b8681
--- /dev/null
+++ b/tests/t-conffile-replaces-diverted/pkg-conff-0/DEBIAN/conffiles
@@ -0,0 +1 @@
+/test/conffile
diff --git a/tests/t-conffile-replaces-diverted/pkg-conff-0/DEBIAN/control b/tests/t-conffile-replaces-diverted/pkg-conff-0/DEBIAN/control
new file mode 100644
index 0000000..13bd5aa
--- /dev/null
+++ b/tests/t-conffile-replaces-diverted/pkg-conff-0/DEBIAN/control
@@ -0,0 +1,7 @@
+Package: pkg-conff
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - provide a conffile
diff --git a/tests/t-conffile-replaces-diverted/pkg-conff-0/test/conffile b/tests/t-conffile-replaces-diverted/pkg-conff-0/test/conffile
new file mode 100644
index 0000000..08db759
--- /dev/null
+++ b/tests/t-conffile-replaces-diverted/pkg-conff-0/test/conffile
@@ -0,0 +1 @@
+This is a conffile.
diff --git a/tests/t-conffile-replaces-diverted/pkg-conff-1/DEBIAN/control b/tests/t-conffile-replaces-diverted/pkg-conff-1/DEBIAN/control
new file mode 100644
index 0000000..bd499f5
--- /dev/null
+++ b/tests/t-conffile-replaces-diverted/pkg-conff-1/DEBIAN/control
@@ -0,0 +1,7 @@
+Package: pkg-conff
+Version: 1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - provided a conffile, not anymore
diff --git a/tests/t-conffile-replaces-diverted/pkg-conff-move/DEBIAN/conffiles b/tests/t-conffile-replaces-diverted/pkg-conff-move/DEBIAN/conffiles
new file mode 100644
index 0000000..e2b8681
--- /dev/null
+++ b/tests/t-conffile-replaces-diverted/pkg-conff-move/DEBIAN/conffiles
@@ -0,0 +1 @@
+/test/conffile
diff --git a/tests/t-conffile-replaces-diverted/pkg-conff-move/DEBIAN/control b/tests/t-conffile-replaces-diverted/pkg-conff-move/DEBIAN/control
new file mode 100644
index 0000000..bcbdffa
--- /dev/null
+++ b/tests/t-conffile-replaces-diverted/pkg-conff-move/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-conff-move
+Version: 1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Replaces: pkg-conff (<< 1)
+Description: test package - takeover a conffile
diff --git a/tests/t-conffile-replaces-diverted/pkg-conff-move/test/conffile b/tests/t-conffile-replaces-diverted/pkg-conff-move/test/conffile
new file mode 100644
index 0000000..08db759
--- /dev/null
+++ b/tests/t-conffile-replaces-diverted/pkg-conff-move/test/conffile
@@ -0,0 +1 @@
+This is a conffile.