summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-replaces-existing
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-conffile-replaces-existing
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-conffile-replaces-existing')
-rw-r--r--tests/t-conffile-replaces-existing/Makefile48
-rw-r--r--tests/t-conffile-replaces-existing/pkg-conff-original-0/DEBIAN/conffiles1
-rw-r--r--tests/t-conffile-replaces-existing/pkg-conff-original-0/DEBIAN/control8
-rw-r--r--tests/t-conffile-replaces-existing/pkg-conff-original-0/test-conffile1
-rw-r--r--tests/t-conffile-replaces-existing/pkg-conff-original-0/test-original0
-rw-r--r--tests/t-conffile-replaces-existing/pkg-conff-original-1/DEBIAN/conffiles1
-rw-r--r--tests/t-conffile-replaces-existing/pkg-conff-original-1/DEBIAN/control8
-rw-r--r--tests/t-conffile-replaces-existing/pkg-conff-original-1/test-conffile1
-rw-r--r--tests/t-conffile-replaces-existing/pkg-conff-original-1/test-original0
-rw-r--r--tests/t-conffile-replaces-existing/pkg-conff-takeover/DEBIAN/conffiles1
-rw-r--r--tests/t-conffile-replaces-existing/pkg-conff-takeover/DEBIAN/control9
-rw-r--r--tests/t-conffile-replaces-existing/pkg-conff-takeover/test-conffile1
-rw-r--r--tests/t-conffile-replaces-existing/pkg-conff-takeover/test-takeover0
-rw-r--r--tests/t-conffile-replaces-existing/ref-conffile1
14 files changed, 80 insertions, 0 deletions
diff --git a/tests/t-conffile-replaces-existing/Makefile b/tests/t-conffile-replaces-existing/Makefile
new file mode 100644
index 0000000..6c3d617
--- /dev/null
+++ b/tests/t-conffile-replaces-existing/Makefile
@@ -0,0 +1,48 @@
+TESTS_DEB := pkg-conff-original-0 pkg-conff-original-1 pkg-conff-takeover
+
+include ../Test.mk
+
+TEST_CASES += test-two-run-ordered
+TEST_CASES += test-one-run-ordered
+TEST_CASES += test-two-run-reverse
+TEST_CASES += test-one-run-reverse
+
+test-case: $(TEST_CASES)
+
+define VERIFY
+$(call pkg_is_installed,pkg-conff-original)
+$(call pkg_is_installed,pkg-conff-takeover)
+test "`$(DPKG_QUERY) -S /test-conffile`" = "pkg-conff-takeover: /test-conffile"
+cmp ref-conffile "$(DPKG_INSTDIR)/test-conffile"
+endef
+
+test-two-run-ordered:
+ # test-two-run-ordered
+ $(DPKG_INSTALL) pkg-conff-original-0.deb
+ $(DPKG_INSTALL) pkg-conff-original-1.deb
+ $(DPKG_INSTALL) pkg-conff-takeover.deb
+ $(VERIFY)
+ $(DPKG_PURGE) pkg-conff-original pkg-conff-takeover
+
+test-one-run-ordered:
+ # test-one-run-ordered
+ $(DPKG_INSTALL) pkg-conff-original-0.deb
+ $(DPKG_INSTALL) pkg-conff-original-1.deb pkg-conff-takeover.deb
+ $(VERIFY)
+ $(DPKG_PURGE) pkg-conff-original pkg-conff-takeover
+
+test-two-run-reverse:
+ # test-two-run-reverse
+ $(DPKG_INSTALL) pkg-conff-original-0.deb
+ $(DPKG_INSTALL) pkg-conff-takeover.deb
+ $(DPKG_INSTALL) pkg-conff-original-1.deb
+ $(VERIFY)
+ $(DPKG_PURGE) pkg-conff-original pkg-conff-takeover
+
+test-one-run-reverse:
+ # test-one-run-reverse
+ $(DPKG_INSTALL) pkg-conff-original-0.deb
+ $(DPKG_INSTALL) pkg-conff-takeover.deb pkg-conff-original-1.deb
+ $(VERIFY)
+ $(DPKG_PURGE) pkg-conff-original pkg-conff-takeover
+
diff --git a/tests/t-conffile-replaces-existing/pkg-conff-original-0/DEBIAN/conffiles b/tests/t-conffile-replaces-existing/pkg-conff-original-0/DEBIAN/conffiles
new file mode 100644
index 0000000..4fad7e9
--- /dev/null
+++ b/tests/t-conffile-replaces-existing/pkg-conff-original-0/DEBIAN/conffiles
@@ -0,0 +1 @@
+/test-conffile
diff --git a/tests/t-conffile-replaces-existing/pkg-conff-original-0/DEBIAN/control b/tests/t-conffile-replaces-existing/pkg-conff-original-0/DEBIAN/control
new file mode 100644
index 0000000..523e417
--- /dev/null
+++ b/tests/t-conffile-replaces-existing/pkg-conff-original-0/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-conff-original
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - provide a conffile
+
diff --git a/tests/t-conffile-replaces-existing/pkg-conff-original-0/test-conffile b/tests/t-conffile-replaces-existing/pkg-conff-original-0/test-conffile
new file mode 100644
index 0000000..995e78d
--- /dev/null
+++ b/tests/t-conffile-replaces-existing/pkg-conff-original-0/test-conffile
@@ -0,0 +1 @@
+test original 0
diff --git a/tests/t-conffile-replaces-existing/pkg-conff-original-0/test-original b/tests/t-conffile-replaces-existing/pkg-conff-original-0/test-original
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/t-conffile-replaces-existing/pkg-conff-original-0/test-original
diff --git a/tests/t-conffile-replaces-existing/pkg-conff-original-1/DEBIAN/conffiles b/tests/t-conffile-replaces-existing/pkg-conff-original-1/DEBIAN/conffiles
new file mode 100644
index 0000000..4fad7e9
--- /dev/null
+++ b/tests/t-conffile-replaces-existing/pkg-conff-original-1/DEBIAN/conffiles
@@ -0,0 +1 @@
+/test-conffile
diff --git a/tests/t-conffile-replaces-existing/pkg-conff-original-1/DEBIAN/control b/tests/t-conffile-replaces-existing/pkg-conff-original-1/DEBIAN/control
new file mode 100644
index 0000000..aebf74d
--- /dev/null
+++ b/tests/t-conffile-replaces-existing/pkg-conff-original-1/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-conff-original
+Version: 1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - provide a conffile
+
diff --git a/tests/t-conffile-replaces-existing/pkg-conff-original-1/test-conffile b/tests/t-conffile-replaces-existing/pkg-conff-original-1/test-conffile
new file mode 100644
index 0000000..326ec44
--- /dev/null
+++ b/tests/t-conffile-replaces-existing/pkg-conff-original-1/test-conffile
@@ -0,0 +1 @@
+test original 1
diff --git a/tests/t-conffile-replaces-existing/pkg-conff-original-1/test-original b/tests/t-conffile-replaces-existing/pkg-conff-original-1/test-original
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/t-conffile-replaces-existing/pkg-conff-original-1/test-original
diff --git a/tests/t-conffile-replaces-existing/pkg-conff-takeover/DEBIAN/conffiles b/tests/t-conffile-replaces-existing/pkg-conff-takeover/DEBIAN/conffiles
new file mode 100644
index 0000000..4fad7e9
--- /dev/null
+++ b/tests/t-conffile-replaces-existing/pkg-conff-takeover/DEBIAN/conffiles
@@ -0,0 +1 @@
+/test-conffile
diff --git a/tests/t-conffile-replaces-existing/pkg-conff-takeover/DEBIAN/control b/tests/t-conffile-replaces-existing/pkg-conff-takeover/DEBIAN/control
new file mode 100644
index 0000000..1f1e038
--- /dev/null
+++ b/tests/t-conffile-replaces-existing/pkg-conff-takeover/DEBIAN/control
@@ -0,0 +1,9 @@
+Package: pkg-conff-takeover
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Replaces: pkg-conff-original
+Description: test package - conffile replaces takeover
+
diff --git a/tests/t-conffile-replaces-existing/pkg-conff-takeover/test-conffile b/tests/t-conffile-replaces-existing/pkg-conff-takeover/test-conffile
new file mode 100644
index 0000000..82fe7fe
--- /dev/null
+++ b/tests/t-conffile-replaces-existing/pkg-conff-takeover/test-conffile
@@ -0,0 +1 @@
+test takeover
diff --git a/tests/t-conffile-replaces-existing/pkg-conff-takeover/test-takeover b/tests/t-conffile-replaces-existing/pkg-conff-takeover/test-takeover
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/t-conffile-replaces-existing/pkg-conff-takeover/test-takeover
diff --git a/tests/t-conffile-replaces-existing/ref-conffile b/tests/t-conffile-replaces-existing/ref-conffile
new file mode 100644
index 0000000..82fe7fe
--- /dev/null
+++ b/tests/t-conffile-replaces-existing/ref-conffile
@@ -0,0 +1 @@
+test takeover