summaryrefslogtreecommitdiffstats
path: root/tests/t-dir-leftover-parents/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-dir-leftover-parents/Makefile
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-dir-leftover-parents/Makefile')
-rw-r--r--tests/t-dir-leftover-parents/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/t-dir-leftover-parents/Makefile b/tests/t-dir-leftover-parents/Makefile
new file mode 100644
index 0000000..35e2718
--- /dev/null
+++ b/tests/t-dir-leftover-parents/Makefile
@@ -0,0 +1,16 @@
+TESTS_DEB := pkg-dir-shared pkg-dir-shared-notempty
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-dir-shared.deb
+ $(DPKG_INSTALL) pkg-dir-shared-notempty.deb
+ $(DPKG_REMOVE) pkg-dir-shared-notempty
+ $(DPKG_PURGE) pkg-dir-shared
+ $(DPKG_PURGE) pkg-dir-shared-notempty
+ test ! -d "$(DPKG_INSTDIR)/test-dir"
+
+test-clean:
+ $(DPKG_PURGE) pkg-dir-shared
+ $(DPKG_PURGE) pkg-dir-shared-notempty
+ $(BEROOT) rm -rf "$(DPKG_INSTDIR)/test-dir"