summaryrefslogtreecommitdiffstats
path: root/tests/t-field-priority/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-field-priority/Makefile
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-field-priority/Makefile')
-rw-r--r--tests/t-field-priority/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/t-field-priority/Makefile b/tests/t-field-priority/Makefile
new file mode 100644
index 0000000..08239e7
--- /dev/null
+++ b/tests/t-field-priority/Makefile
@@ -0,0 +1,12 @@
+TESTS_DEB := pkg-priority
+
+include ../Test.mk
+
+test-case:
+ # test for unknown priority values
+ $(DPKG_INSTALL) pkg-priority.deb
+ $(call pkg_is_installed,pkg-priority)
+ $(call pkg_field_is,pkg-priority,Priority,value not known)
+
+test-clean:
+ $(DPKG_PURGE) pkg-priority