summaryrefslogtreecommitdiffstats
path: root/tests/t-maintscript-leak/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-maintscript-leak/Makefile
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-maintscript-leak/Makefile')
-rw-r--r--tests/t-maintscript-leak/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/t-maintscript-leak/Makefile b/tests/t-maintscript-leak/Makefile
new file mode 100644
index 0000000..c01646a
--- /dev/null
+++ b/tests/t-maintscript-leak/Makefile
@@ -0,0 +1,14 @@
+TESTS_DEB := pkg-maintscript-leak
+
+include ../Test.mk
+
+test-case:
+ # Check for leaks on install
+ $(DPKG_INSTALL) pkg-maintscript-leak.deb
+ # Check for leaks on upgrade
+ $(DPKG_INSTALL) pkg-maintscript-leak.deb
+ # Check for leaks on removal
+ $(DPKG_PURGE) pkg-maintscript-leak
+
+test-clean:
+ $(DPKG_PURGE) pkg-maintscript-leak