summaryrefslogtreecommitdiffstats
path: root/tests/t-option-recursive
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 14:58:51 +0000
commitcbffab246997fb5a06211dfb706b54e5ae5bb59f (patch)
tree0573c5d96f58d74d76a49c0f2a70398e389a36d3 /tests/t-option-recursive
parentInitial commit. (diff)
downloaddpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.tar.xz
dpkg-cbffab246997fb5a06211dfb706b54e5ae5bb59f.zip
Adding upstream version 1.21.22.upstream/1.21.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-option-recursive')
-rw-r--r--tests/t-option-recursive/Makefile25
-rw-r--r--tests/t-option-recursive/dir-a/pkg-a/DEBIAN/control7
-rw-r--r--tests/t-option-recursive/dir-b/dir-bb/pkg-b/DEBIAN/control7
-rw-r--r--tests/t-option-recursive/pkg-c/DEBIAN/control7
4 files changed, 46 insertions, 0 deletions
diff --git a/tests/t-option-recursive/Makefile b/tests/t-option-recursive/Makefile
new file mode 100644
index 0000000..c0108ed
--- /dev/null
+++ b/tests/t-option-recursive/Makefile
@@ -0,0 +1,25 @@
+TESTS_DEB := dir-a/pkg-a dir-b/dir-bb/pkg-b pkg-c
+
+include ../Test.mk
+
+test-case:
+ # Try recursive directory unpacking of packages
+ $(DPKG_INSTALL) -R .
+ $(call pkg_is_unpacked,pkg-a)
+ $(call pkg_is_unpacked,pkg-b)
+ $(call pkg_is_unpacked,pkg-c)
+
+ $(DPKG_PURGE) pkg-a
+ $(DPKG_PURGE) pkg-b
+ $(DPKG_PURGE) pkg-c
+
+ # Try recursive directory installation of packages
+ $(DPKG_INSTALL) -R .
+ $(call pkg_is_installed,pkg-a)
+ $(call pkg_is_installed,pkg-b)
+ $(call pkg_is_installed,pkg-c)
+
+test-clean:
+ $(DPKG_PURGE) pkg-a
+ $(DPKG_PURGE) pkg-b
+ $(DPKG_PURGE) pkg-c
diff --git a/tests/t-option-recursive/dir-a/pkg-a/DEBIAN/control b/tests/t-option-recursive/dir-a/pkg-a/DEBIAN/control
new file mode 100644
index 0000000..af9ae1a
--- /dev/null
+++ b/tests/t-option-recursive/dir-a/pkg-a/DEBIAN/control
@@ -0,0 +1,7 @@
+Package: pkg-a
+Version: 0.0-1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - normal
diff --git a/tests/t-option-recursive/dir-b/dir-bb/pkg-b/DEBIAN/control b/tests/t-option-recursive/dir-b/dir-bb/pkg-b/DEBIAN/control
new file mode 100644
index 0000000..e70151f
--- /dev/null
+++ b/tests/t-option-recursive/dir-b/dir-bb/pkg-b/DEBIAN/control
@@ -0,0 +1,7 @@
+Package: pkg-b
+Version: 0.0-1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - normal
diff --git a/tests/t-option-recursive/pkg-c/DEBIAN/control b/tests/t-option-recursive/pkg-c/DEBIAN/control
new file mode 100644
index 0000000..2ae6c72
--- /dev/null
+++ b/tests/t-option-recursive/pkg-c/DEBIAN/control
@@ -0,0 +1,7 @@
+Package: pkg-c
+Version: 0.0-1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - normal