summaryrefslogtreecommitdiffstats
path: root/scripts/mk/buildopts.mk
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/mk/buildopts.mk')
-rw-r--r--scripts/mk/buildopts.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/scripts/mk/buildopts.mk b/scripts/mk/buildopts.mk
new file mode 100644
index 0000000..c957777
--- /dev/null
+++ b/scripts/mk/buildopts.mk
@@ -0,0 +1,10 @@
+# This Makefile fragment (since dpkg 1.20.1) parses option arguments from
+# DEB_BUILD_OPTIONS, and exposes these as variables.
+#
+# Defines the following variables:
+#
+# DEB_BUILD_OPTION_PARALLEL: the argument for the parallel=N option.
+
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ DEB_BUILD_OPTION_PARALLEL = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+endif