summaryrefslogtreecommitdiffstats
path: root/tests/t-conflict-provide-replace-interface
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-conflict-provide-replace-interface')
-rw-r--r--tests/t-conflict-provide-replace-interface/Makefile18
-rw-r--r--tests/t-conflict-provide-replace-interface/pkg-a/DEBIAN/control10
-rw-r--r--tests/t-conflict-provide-replace-interface/pkg-b/DEBIAN/control11
3 files changed, 39 insertions, 0 deletions
diff --git a/tests/t-conflict-provide-replace-interface/Makefile b/tests/t-conflict-provide-replace-interface/Makefile
new file mode 100644
index 0000000..6aefafb
--- /dev/null
+++ b/tests/t-conflict-provide-replace-interface/Makefile
@@ -0,0 +1,18 @@
+TESTS_DEB := pkg-a pkg-b
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-a.deb
+ # The user was not explicit in the request, fail
+ ! $(DPKG_INSTALL) pkg-b.deb
+ # Even if requesting auto-deconfigure the request is not explicit
+ # enough, fail
+ ! $(DPKG_INSTALL) -B pkg-b.deb
+ # Set up the desired transaction
+ echo pkg-a deinstall | $(BEROOT) $(DPKG) --set-selections
+ $(DPKG_INSTALL) pkg-b.deb
+
+test-clean:
+ $(DPKG_PURGE) pkg-b
+ -$(DPKG_PURGE) pkg-a
diff --git a/tests/t-conflict-provide-replace-interface/pkg-a/DEBIAN/control b/tests/t-conflict-provide-replace-interface/pkg-a/DEBIAN/control
new file mode 100644
index 0000000..3e079f1
--- /dev/null
+++ b/tests/t-conflict-provide-replace-interface/pkg-a/DEBIAN/control
@@ -0,0 +1,10 @@
+Package: pkg-a
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Conflicts: pkg-iface
+Replaces: pkg-iface
+Provides: pkg-iface
+Description: test package - package providing an interface
diff --git a/tests/t-conflict-provide-replace-interface/pkg-b/DEBIAN/control b/tests/t-conflict-provide-replace-interface/pkg-b/DEBIAN/control
new file mode 100644
index 0000000..80b99d7
--- /dev/null
+++ b/tests/t-conflict-provide-replace-interface/pkg-b/DEBIAN/control
@@ -0,0 +1,11 @@
+Package: pkg-b
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Conflicts: pkg-iface
+Replaces: pkg-iface
+Provides: pkg-iface
+Description: test package - package providing an interface
+