summaryrefslogtreecommitdiffstats
path: root/tests/t-file-conflicts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-file-conflicts/Makefile')
-rw-r--r--tests/t-file-conflicts/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/t-file-conflicts/Makefile b/tests/t-file-conflicts/Makefile
new file mode 100644
index 0000000..4eeb0f5
--- /dev/null
+++ b/tests/t-file-conflicts/Makefile
@@ -0,0 +1,15 @@
+TESTS_DEB := pkg-a pkg-b
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-a.deb
+ # test if the conflicting package fails on install
+ ! $(DPKG_INSTALL) pkg-b.deb
+
+test-clean:
+ # tell dpkg we do not want pkg-b, even if we asked for it and failed
+ echo pkg-b purge | $(BEROOT) $(DPKG) --set-selections
+ -$(DPKG_PURGE) pkg-b
+ $(DPKG_PURGE) pkg-a
+