summaryrefslogtreecommitdiffstats
path: root/tests/t-option-recursive/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-option-recursive/Makefile')
-rw-r--r--tests/t-option-recursive/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/t-option-recursive/Makefile b/tests/t-option-recursive/Makefile
new file mode 100644
index 0000000..c0108ed
--- /dev/null
+++ b/tests/t-option-recursive/Makefile
@@ -0,0 +1,25 @@
+TESTS_DEB := dir-a/pkg-a dir-b/dir-bb/pkg-b pkg-c
+
+include ../Test.mk
+
+test-case:
+ # Try recursive directory unpacking of packages
+ $(DPKG_INSTALL) -R .
+ $(call pkg_is_unpacked,pkg-a)
+ $(call pkg_is_unpacked,pkg-b)
+ $(call pkg_is_unpacked,pkg-c)
+
+ $(DPKG_PURGE) pkg-a
+ $(DPKG_PURGE) pkg-b
+ $(DPKG_PURGE) pkg-c
+
+ # Try recursive directory installation of packages
+ $(DPKG_INSTALL) -R .
+ $(call pkg_is_installed,pkg-a)
+ $(call pkg_is_installed,pkg-b)
+ $(call pkg_is_installed,pkg-c)
+
+test-clean:
+ $(DPKG_PURGE) pkg-a
+ $(DPKG_PURGE) pkg-b
+ $(DPKG_PURGE) pkg-c