summaryrefslogtreecommitdiffstats
path: root/tests/t-provides-arch-qualified/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-provides-arch-qualified/Makefile')
-rw-r--r--tests/t-provides-arch-qualified/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/t-provides-arch-qualified/Makefile b/tests/t-provides-arch-qualified/Makefile
new file mode 100644
index 0000000..0334b19
--- /dev/null
+++ b/tests/t-provides-arch-qualified/Makefile
@@ -0,0 +1,16 @@
+TESTS_DEB := pkg-a pkg-b
+
+include ../Test.mk
+
+test-case:
+ $(DPKG) --add-architecture i386
+ $(DPKG) --add-architecture amd64
+ $(DPKG_INSTALL) pkg-a.deb
+ # test if the conflicting package fails on install
+ ! $(DPKG_INSTALL) pkg-b.deb
+
+test-clean:
+ $(DPKG_PURGE) pkg-b
+ $(DPKG_PURGE) pkg-a
+ $(DPKG) --remove-architecture i386
+ $(DPKG) --remove-architecture amd64