summaryrefslogtreecommitdiffstats
path: root/tests/t-unpack-device/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-unpack-device/Makefile')
-rw-r--r--tests/t-unpack-device/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/t-unpack-device/Makefile b/tests/t-unpack-device/Makefile
new file mode 100644
index 0000000..0dcb3ca
--- /dev/null
+++ b/tests/t-unpack-device/Makefile
@@ -0,0 +1,26 @@
+PKG := pkg-device
+
+TESTS_DEB := $(PKG)
+
+include ../Test.mk
+
+$(PKG)/test-null:
+ $(BEROOT) mknod $@ c 1 3
+
+$(PKG)/test-ram0:
+ $(BEROOT) mknod $@ b 1 0
+
+build-hook: $(PKG)/test-null $(PKG)/test-ram0
+
+clean-hook:
+ rm -f $(PKG)/test-null
+ rm -f $(PKG)/test-ram0
+
+test-case:
+ # test unpacking device files
+ $(DPKG_INSTALL) pkg-device.deb
+ $(call pkg_is_installed,pkg-device)
+
+test-clean:
+ $(DPKG_PURGE) pkg-device
+