summaryrefslogtreecommitdiffstats
path: root/tests/t-unpack-divert-hardlink
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-unpack-divert-hardlink')
-rw-r--r--tests/t-unpack-divert-hardlink/Makefile31
-rw-r--r--tests/t-unpack-divert-hardlink/pkg-hardlink/DEBIAN/control7
-rw-r--r--tests/t-unpack-divert-hardlink/pkg-hardlink/test-file1
3 files changed, 39 insertions, 0 deletions
diff --git a/tests/t-unpack-divert-hardlink/Makefile b/tests/t-unpack-divert-hardlink/Makefile
new file mode 100644
index 0000000..75287f7
--- /dev/null
+++ b/tests/t-unpack-divert-hardlink/Makefile
@@ -0,0 +1,31 @@
+PKG := pkg-hardlink
+
+TESTS_DEB := $(PKG)
+
+include ../Test.mk
+
+$(PKG)/test-hardlink:
+ link $(PKG)/test-file $@
+
+build-hook: $(PKG)/test-hardlink
+
+clean-hook:
+ rm -f $(PKG)/test-hardlink
+
+test-case:
+ $(DPKG_DIVERT_ADD) /test-file
+ $(DPKG_DIVERT_ADD) /test-hardlink
+ # test if unpack can divert a hardlink
+ $(DPKG_INSTALL) pkg-hardlink.deb
+ $(call pkg_is_installed,pkg-hardlink)
+ test -f '$(DPKG_INSTDIR)/test-file.distrib'
+ test -f '$(DPKG_INSTDIR)/test-hardlink.distrib'
+ cmp '$(DPKG_INSTDIR)/test-file.distrib' \
+ '$(DPKG_INSTDIR)/test-hardlink.distrib'
+ test "`stat -c '%i' '$(DPKG_INSTDIR)/test-file.distrib'`" = \
+ "`stat -c '%i' '$(DPKG_INSTDIR)/test-hardlink.distrib'`"
+
+test-clean:
+ $(DPKG_PURGE) pkg-hardlink
+ $(DPKG_DIVERT_DEL) /test-file
+ $(DPKG_DIVERT_DEL) /test-hardlink
diff --git a/tests/t-unpack-divert-hardlink/pkg-hardlink/DEBIAN/control b/tests/t-unpack-divert-hardlink/pkg-hardlink/DEBIAN/control
new file mode 100644
index 0000000..da36e99
--- /dev/null
+++ b/tests/t-unpack-divert-hardlink/pkg-hardlink/DEBIAN/control
@@ -0,0 +1,7 @@
+Package: pkg-hardlink
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - provide two hard linked files
diff --git a/tests/t-unpack-divert-hardlink/pkg-hardlink/test-file b/tests/t-unpack-divert-hardlink/pkg-hardlink/test-file
new file mode 100644
index 0000000..94e47d3
--- /dev/null
+++ b/tests/t-unpack-divert-hardlink/pkg-hardlink/test-file
@@ -0,0 +1 @@
+test diverted