summaryrefslogtreecommitdiffstats
path: root/tests/t-unpack-divert-nowarn
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-unpack-divert-nowarn')
-rw-r--r--tests/t-unpack-divert-nowarn/Makefile10
-rw-r--r--tests/t-unpack-divert-nowarn/pkg-divert-unpacking/DEBIAN/control8
-rwxr-xr-xtests/t-unpack-divert-nowarn/pkg-divert-unpacking/DEBIAN/postrm7
-rwxr-xr-xtests/t-unpack-divert-nowarn/pkg-divert-unpacking/DEBIAN/preinst10
-rw-r--r--tests/t-unpack-divert-nowarn/pkg-divert-unpacking/test-file1
-rw-r--r--tests/t-unpack-divert-nowarn/pkg-files/DEBIAN/control7
-rw-r--r--tests/t-unpack-divert-nowarn/pkg-files/test-file1
7 files changed, 44 insertions, 0 deletions
diff --git a/tests/t-unpack-divert-nowarn/Makefile b/tests/t-unpack-divert-nowarn/Makefile
new file mode 100644
index 0000000..aa56877
--- /dev/null
+++ b/tests/t-unpack-divert-nowarn/Makefile
@@ -0,0 +1,10 @@
+TESTS_DEB := pkg-files pkg-divert-unpacking
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-files.deb
+ $(DPKG_UNPACK) pkg-divert-unpacking.deb
+
+test-clean:
+ $(DPKG_PURGE) pkg-files pkg-divert-unpacking
diff --git a/tests/t-unpack-divert-nowarn/pkg-divert-unpacking/DEBIAN/control b/tests/t-unpack-divert-nowarn/pkg-divert-unpacking/DEBIAN/control
new file mode 100644
index 0000000..d677e02
--- /dev/null
+++ b/tests/t-unpack-divert-nowarn/pkg-divert-unpacking/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-divert-unpacking
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - divert a file w/o having ever unpacked
+ This should not result in any warning.
diff --git a/tests/t-unpack-divert-nowarn/pkg-divert-unpacking/DEBIAN/postrm b/tests/t-unpack-divert-nowarn/pkg-divert-unpacking/DEBIAN/postrm
new file mode 100755
index 0000000..8d834a5
--- /dev/null
+++ b/tests/t-unpack-divert-nowarn/pkg-divert-unpacking/DEBIAN/postrm
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+set -e
+
+if [ "$1" = "purge" ]; then
+ dpkg-divert --quiet --remove --rename /test-file
+fi
diff --git a/tests/t-unpack-divert-nowarn/pkg-divert-unpacking/DEBIAN/preinst b/tests/t-unpack-divert-nowarn/pkg-divert-unpacking/DEBIAN/preinst
new file mode 100755
index 0000000..a61ad11
--- /dev/null
+++ b/tests/t-unpack-divert-nowarn/pkg-divert-unpacking/DEBIAN/preinst
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+set -e
+
+if [ "$1" = "install" ] || [ "$1" = "upgrade" ]; then
+ dpkg-divert --quiet --package pkg-divert-unpacking --rename \
+ --divert /test-file.diverted --add /test-file 2>&1 | \
+ grep "warning: " && echo "Fail: warning in output" && exit 1 ||
+ echo Pass
+fi
diff --git a/tests/t-unpack-divert-nowarn/pkg-divert-unpacking/test-file b/tests/t-unpack-divert-nowarn/pkg-divert-unpacking/test-file
new file mode 100644
index 0000000..94e47d3
--- /dev/null
+++ b/tests/t-unpack-divert-nowarn/pkg-divert-unpacking/test-file
@@ -0,0 +1 @@
+test diverted
diff --git a/tests/t-unpack-divert-nowarn/pkg-files/DEBIAN/control b/tests/t-unpack-divert-nowarn/pkg-files/DEBIAN/control
new file mode 100644
index 0000000..b616257
--- /dev/null
+++ b/tests/t-unpack-divert-nowarn/pkg-files/DEBIAN/control
@@ -0,0 +1,7 @@
+Package: pkg-files
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - provide a file
diff --git a/tests/t-unpack-divert-nowarn/pkg-files/test-file b/tests/t-unpack-divert-nowarn/pkg-files/test-file
new file mode 100644
index 0000000..6fbc8b5
--- /dev/null
+++ b/tests/t-unpack-divert-nowarn/pkg-files/test-file
@@ -0,0 +1 @@
+test init