summaryrefslogtreecommitdiffstats
path: root/tests/t-unpack-symlink
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-unpack-symlink')
-rw-r--r--tests/t-unpack-symlink/Makefile20
-rw-r--r--tests/t-unpack-symlink/pkg-symlink/DEBIAN/control8
-rw-r--r--tests/t-unpack-symlink/pkg-symlink/test-file0
3 files changed, 28 insertions, 0 deletions
diff --git a/tests/t-unpack-symlink/Makefile b/tests/t-unpack-symlink/Makefile
new file mode 100644
index 0000000..518ca4e
--- /dev/null
+++ b/tests/t-unpack-symlink/Makefile
@@ -0,0 +1,20 @@
+TESTS_DEB := pkg-symlink
+
+include ../Test.mk
+
+build-hook:
+ ln -fs test-file pkg-symlink/test-symlink
+
+clean-hook:
+ $(RM) pkg-symlink/test-symlink
+
+test-case:
+ # test unpacking symlinks
+ $(DPKG_INSTALL) pkg-symlink.deb
+ $(call pkg_is_installed,pkg-symlink)
+ test -f "$(DPKG_INSTDIR)/test-file"
+ test -L "$(DPKG_INSTDIR)/test-symlink"
+ test "`readlink '$(DPKG_INSTDIR)/test-symlink'`" = "test-file"
+
+test-clean:
+ $(DPKG_PURGE) pkg-symlink
diff --git a/tests/t-unpack-symlink/pkg-symlink/DEBIAN/control b/tests/t-unpack-symlink/pkg-symlink/DEBIAN/control
new file mode 100644
index 0000000..f57852f
--- /dev/null
+++ b/tests/t-unpack-symlink/pkg-symlink/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-symlink
+Version: 0.0-1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - unpack symlink
+
diff --git a/tests/t-unpack-symlink/pkg-symlink/test-file b/tests/t-unpack-symlink/pkg-symlink/test-file
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/t-unpack-symlink/pkg-symlink/test-file