summaryrefslogtreecommitdiffstats
path: root/tests/t-verify
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-verify')
-rw-r--r--tests/t-verify/Makefile13
-rw-r--r--tests/t-verify/pkg-verify/DEBIAN/control7
-rw-r--r--tests/t-verify/pkg-verify/test-dir/test-data1
-rw-r--r--tests/t-verify/pkg-verify/test-dir/test-digits20
-rw-r--r--tests/t-verify/pkg-verify/test-file1
5 files changed, 42 insertions, 0 deletions
diff --git a/tests/t-verify/Makefile b/tests/t-verify/Makefile
new file mode 100644
index 0000000..2763e84
--- /dev/null
+++ b/tests/t-verify/Makefile
@@ -0,0 +1,13 @@
+TESTS_DEB := pkg-verify
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-verify.deb
+ $(call pkg_is_installed,pkg-verify)
+ $(call stdout_is,$(DPKG_VERIFY) pkg-verify,)
+ $(BEROOT) sh -c "echo 'MODIFIED' >>'$(DPKG_INSTDIR)/test-dir/test-data'"
+ $(call stdout_has,$(DPKG_VERIFY) pkg-verify,^\?\?5\?\?\?\?\?\? /test-dir/test-data$)
+
+test-clean:
+ $(DPKG_PURGE) pkg-verify
diff --git a/tests/t-verify/pkg-verify/DEBIAN/control b/tests/t-verify/pkg-verify/DEBIAN/control
new file mode 100644
index 0000000..5d383a2
--- /dev/null
+++ b/tests/t-verify/pkg-verify/DEBIAN/control
@@ -0,0 +1,7 @@
+Package: pkg-verify
+Version: 0.0-1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - verify
diff --git a/tests/t-verify/pkg-verify/test-dir/test-data b/tests/t-verify/pkg-verify/test-dir/test-data
new file mode 100644
index 0000000..f2f6d87
--- /dev/null
+++ b/tests/t-verify/pkg-verify/test-dir/test-data
@@ -0,0 +1 @@
+some other data
diff --git a/tests/t-verify/pkg-verify/test-dir/test-digits b/tests/t-verify/pkg-verify/test-dir/test-digits
new file mode 100644
index 0000000..0ff3bbb
--- /dev/null
+++ b/tests/t-verify/pkg-verify/test-dir/test-digits
@@ -0,0 +1,20 @@
+1
+2
+3
+4
+5
+6
+7
+8
+9
+10
+11
+12
+13
+14
+15
+16
+17
+18
+19
+20
diff --git a/tests/t-verify/pkg-verify/test-file b/tests/t-verify/pkg-verify/test-file
new file mode 100644
index 0000000..7a1c613
--- /dev/null
+++ b/tests/t-verify/pkg-verify/test-file
@@ -0,0 +1 @@
+some file