summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.library
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.library')
-rw-r--r--lib/Makefile.library27
1 files changed, 27 insertions, 0 deletions
diff --git a/lib/Makefile.library b/lib/Makefile.library
new file mode 100644
index 0000000..f78467a
--- /dev/null
+++ b/lib/Makefile.library
@@ -0,0 +1,27 @@
+all:: subdirs $(LIBRARY).a
+
+install-shlibs-strip::
+
+install-shlibs::
+
+uninstall-shlibs::
+
+real-subdirs::
+
+subdirs:: Makefile
+ $(Q) $(MAKE) -s real-subdirs
+ $(Q) touch subdirs
+
+clean::
+ $(Q) $(RM) -f subdirs
+
+$(LIBRARY).a: $(OBJS)
+ $(E) " GEN_LIB $@"
+ $(Q) (if test -r $@; then $(RM) -f $@.bak && $(MV) $@ $@.bak; fi)
+ $(Q) $(ARGEN) $@ $(OBJS)
+ -@$(RANLIB) $@
+ $(Q) $(RM) -f ../$@
+ $(Q) (cd ..; $(LN) $(LINK_BUILD_FLAGS) \
+ `echo $(my_dir) | sed -e 's;lib/;;'`/$@ $@)
+
+$(LIB)/$(LIBRARY).a: $(LIBRARY).a