summaryrefslogtreecommitdiffstats
path: root/OS/Makefile-Linux
diff options
context:
space:
mode:
Diffstat (limited to 'OS/Makefile-Linux')
-rw-r--r--OS/Makefile-Linux39
1 files changed, 39 insertions, 0 deletions
diff --git a/OS/Makefile-Linux b/OS/Makefile-Linux
new file mode 100644
index 0000000..dfb2fa8
--- /dev/null
+++ b/OS/Makefile-Linux
@@ -0,0 +1,39 @@
+# Exim: OS-specific make file for Linux. This is for modern Linuxes,
+# which use libc6.
+# Copyright (c) The Exim Maintainers 2020
+#
+# For Linux, we assume GNU Make; at time of writing, the only extension
+# used is ?= which is actually portable to other maintained Make variants,
+# just is not POSIX.
+
+HAVE_ICONV=yes
+
+BASENAME_COMMAND=look_for_it
+CHOWN_COMMAND=look_for_it
+CHGRP_COMMAND=look_for_it
+CHMOD_COMMAND=look_for_it
+
+# The system cc may be gcc or clang; do not force gcc
+CC=cc
+# Preserve CFLAGS and CFLAGS_DYNAMIC from the caller/environment
+CFLAGS ?= -O -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+CFLAGS_DYNAMIC ?= -shared -rdynamic
+
+DBMLIB = -ldb
+USE_DB = yes
+
+LIBS = -lcrypt -lm
+LIBRESOLV = -lresolv
+
+X11=/usr/X11R6
+XINCLUDE=-I$(X11)/include
+XLFLAGS=-L$(X11)/lib
+X11_LD_LIB=$(X11)/lib
+
+EXIWHAT_PS_ARG=ax
+EXIWHAT_EGREP_ARG='/exim( |$$)'
+EXIWHAT_MULTIKILL_CMD=killall
+EXIWHAT_MULTIKILL_ARG=exim
+EXIWHAT_KILL_SIGNAL=-USR1
+
+# End