summaryrefslogtreecommitdiffstats
path: root/debian/config-custom
diff options
context:
space:
mode:
Diffstat (limited to 'debian/config-custom')
-rwxr-xr-xdebian/config-custom/create-custom-config-package71
-rw-r--r--debian/config-custom/debian/compat1
-rw-r--r--debian/config-custom/debian/control18
-rw-r--r--debian/config-custom/debian/copyright15
-rw-r--r--debian/config-custom/debian/install2
-rwxr-xr-xdebian/config-custom/debian/rules94
6 files changed, 201 insertions, 0 deletions
diff --git a/debian/config-custom/create-custom-config-package b/debian/config-custom/create-custom-config-package
new file mode 100755
index 0000000..03be647
--- /dev/null
+++ b/debian/config-custom/create-custom-config-package
@@ -0,0 +1,71 @@
+#!/bin/bash
+
+if [ -n "$1" ]; then
+ PACKAGESUFFIX="$1"
+else
+ PACKAGESUFFIX="custom"
+fi
+
+TARGETDIR="../exim4-config-$PACKAGESUFFIX"
+#DEBUG=1
+
+# copy over -changelog, generating a proper changelog entry
+# copy over update-exim4defaults, ip-up.d, email-addresses
+
+dh_testdir
+
+set -e
+
+copytextreplace() {
+ FILE="$1"
+ DSTFILE="$2"
+ DIR="${FILE%/*}"
+ FILE="${FILE##*/}"
+ if [ -z "$DSTFILE" ]; then
+ DSTFILE="$FILE"
+ fi
+ [ $DEBUG ] && echo >&2 "DBG: source $DIR/$FILE"
+ [ $DEBUG ] && echo >&2 "DBG: dst $TARGETDIR/$DIR/$DSTFILE"
+ mkdir -p $TARGETDIR/$DIR
+ if ! [ -e "$TARGETDIR/$DIR/$FILE" ]; then
+ < $DIR/$FILE \
+ sed -e "s/exim4-config/exim4-config-$PACKAGESUFFIX/g" \
+ -e "s/orig-exim4-config-$PACKAGESUFFIX/exim4-config/g" \
+ > $TARGETDIR/$DIR/$DSTFILE
+ chmod --reference=$DIR/$FILE $TARGETDIR/$DIR/$DSTFILE
+ else
+ echo >&2 "ERR: can't write to $TARGETDIR/$DIR/$DSTFILE, file exists"
+ exit 1
+ fi
+}
+
+for file in manpages config templates postinst postrm dirs; do
+ copytextreplace debian/exim4-config.$file exim4-config-$PACKAGESUFFIX.$file
+done
+
+for file in `cat debian/exim4-config.manpages` \
+ `find debian/debconf \( -path '*/.svn/*' -prune \) -or \( -type f -print \)`; do
+ copytextreplace $file
+done
+
+for file in compat control copyright rules install; do
+ copytextreplace debian/config-custom/debian/$file
+done
+
+for file in ip-up.d update-exim4defaults email-addresses; do
+ copytextreplace debian/$file
+done
+
+# manual corrections in target directory
+
+mv $TARGETDIR/debian/config-custom/debian/* $TARGETDIR/debian
+rm -rf $TARGETDIR/debian/config-custom
+chmod 775 $TARGETDIR/debian/rules
+
+# hack changelog
+
+< debian/changelog sed -n "/^exim4/{s/exim4/exim4-config-$PACKAGESUFFIX/p;q;}" > $TARGETDIR/debian/changelog
+echo -e "\n * automatically generated changelog" >> $TARGETDIR/debian/changelog
+< debian/changelog sed -n '/^ --/{p;q;}' >> $TARGETDIR/debian/changelog
+cd $TARGETDIR
+dch --append "generated source package by create-custom-package"
diff --git a/debian/config-custom/debian/compat b/debian/config-custom/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/config-custom/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/config-custom/debian/control b/debian/config-custom/debian/control
new file mode 100644
index 0000000..b98933b
--- /dev/null
+++ b/debian/config-custom/debian/control
@@ -0,0 +1,18 @@
+Source: exim4-config
+Section: mail
+Priority: optional
+Maintainer: locally built <root@localhost>
+Standards-Version: 3.6.1.0
+Build-Depends-Indep: debhelper (>= 4.0.1)
+
+Package: exim4-config
+Architecture: all
+Priority: important
+Conflicts: orig-exim4-config
+Replaces: orig-exim4-config
+Provides: orig-exim4-config, orig-exim4-config-2
+Depends: ${shlibs:Depends}, ${misc:Depends}, exim4-base
+Description: exim4-config locally modified Debian configuration for exim4
+ This package provides the configuration for the exim4 daemon
+ packages. It is a locally built special version derived from
+ orig-exim4-config.
diff --git a/debian/config-custom/debian/copyright b/debian/config-custom/debian/copyright
new file mode 100644
index 0000000..1910196
--- /dev/null
+++ b/debian/config-custom/debian/copyright
@@ -0,0 +1,15 @@
+This is a custom made configuration package for Debian GNU/Linux's
+prepackaged version of exim4, a powerful yet easy to configure mail
+transport agent.
+
+This package was originally made by create-custom-package, a script
+written by Marc Haber <mh+debian-packages@zugschlus.de> using work
+provided by Andreas Metzler <ametzler@downhill.at.eu.org>.
+create-custom-package uses the exim4 source package to build this
+source package.
+
+The files in this package are free software; you can redistribute them
+and/or modify them under the terms of the GNU General Public License
+as published by the Free Software Foundation; either version 2, or (at
+your option) any later version. Full text of the license can be found
+at /usr/share/common-licenses/GPL
diff --git a/debian/config-custom/debian/install b/debian/config-custom/debian/install
new file mode 100644
index 0000000..718d496
--- /dev/null
+++ b/debian/config-custom/debian/install
@@ -0,0 +1,2 @@
+debian/debconf/update-exim4.conf.template usr/sbin
+debian/debconf/exim4.conf.template etc/exim4
diff --git a/debian/config-custom/debian/rules b/debian/config-custom/debian/rules
new file mode 100755
index 0000000..6dc6b79
--- /dev/null
+++ b/debian/config-custom/debian/rules
@@ -0,0 +1,94 @@
+#!/usr/bin/make -f
+# debian/rules for exim4-config-custom
+# This file is public domain software, originally written by Joey Hess.
+#
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+buildname=$${build:-`$(SHELL) scripts/os-type`-`$(SHELL) scripts/arch-type`}
+
+DEBIAN:=$(shell pwd)/debian
+
+configure: configure-stamp
+
+# the patches might change src/EDITME.
+configure-stamp:
+ dh_testdir
+ touch configure-stamp
+
+build-indep: build-indep-stamp
+build-indep-stamp:
+ dh_testdir
+ touch build-indep-stamp
+
+build: build-indep
+
+clean: cleanfiles
+
+cleanfiles:
+ dh_testdir
+ dh_testroot
+ rm -f build-indep-stamp configure-stamp install-stamp debian/files
+ rm -f debian/debconf/exim4.conf.template
+
+ # Add here commands to clean up after the build process.
+ dh_clean
+
+install: install-stamp
+install-stamp: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ install -m 755 debian/debconf/update-exim4.conf debian/exim4-config/usr/sbin
+ install -m 755 $(DEBIAN)/update-exim4defaults $(DEBIAN)/exim4-config/usr/sbin
+ # install -m644 debian/debconf/exim4.conf.template debian/exim4-config/etc/exim4
+
+ # ship a copy in examples
+ # install -m644 debian/debconf/exim4.conf.template debian/exim4-config/usr/share/doc/exim4-config/examples/exim4.conf.template.debconf
+ install -m644 debian/email-addresses debian/exim4-config/etc
+ install -m755 debian/ip-up.d debian/exim4-config/etc/ppp/ip-up.d/exim4
+ cd $(DEBIAN)/debconf/conf.d && \
+ tar cf - `find \( -path '*/.svn/*' -prune \) -or \( -type f -print \)` | \
+ { cd $(DEBIAN)/exim4-config/etc/exim4/conf.d/ && \
+ tar xf - ; }
+ chmod 755 debian/debconf/update-exim4.conf.template
+ CONFDIR=$(DEBIAN)/debconf debian/debconf/update-exim4.conf.template --nobackup --run
+
+# dh_movefiles
+ touch install-stamp
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_testdir -i
+ dh_testroot -i
+ dh_installchangelogs -i
+ dh_installdocs -i
+ dh_installexamples -i
+ dh_installmenu -i
+ dh_installdebconf -i
+ dh_installlogrotate -i
+# dh_installemacsen -i
+ dh_installpam -i
+ dh_installmime -i
+# dh_installinit -i
+ dh_installcron -i
+# dh_installinfo -i
+# dh_undocumented -i
+ dh_installman -i
+ dh_install -i
+ dh_strip -i
+ dh_link -i
+ dh_compress -i
+ dh_fixperms -i
+# dh_makeshlibs -i
+ dh_installdeb -i
+# dh_perl -i
+ dh_shlibdeps -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
+
+binary: binary-indep
+.PHONY: build clean binary-indep binary-arch binary install