summaryrefslogtreecommitdiffstats
path: root/build/binary-location.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /build/binary-location.mk
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/binary-location.mk')
-rw-r--r--build/binary-location.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/build/binary-location.mk b/build/binary-location.mk
new file mode 100644
index 0000000000..19ae4b55f3
--- /dev/null
+++ b/build/binary-location.mk
@@ -0,0 +1,19 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+# finds the location of the browser and puts it in the variable $(browser_path)
+
+ifneq (,$(filter WINNT,$(OS_ARCH)))
+program = $(MOZ_APP_NAME)$(BIN_SUFFIX)
+else
+program = $(MOZ_APP_NAME)-bin$(BIN_SUFFIX)
+endif
+
+TARGET_DIST = $(TARGET_DEPTH)/dist
+
+ifeq ($(OS_ARCH),Darwin)
+browser_path = $(TARGET_DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/MacOS/$(program)
+else
+browser_path = $(TARGET_DIST)/bin/$(program)
+endif