summaryrefslogtreecommitdiffstats
path: root/dom/html/HTMLDetailsElement.h
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /dom/html/HTMLDetailsElement.h
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/html/HTMLDetailsElement.h')
-rw-r--r--dom/html/HTMLDetailsElement.h65
1 files changed, 65 insertions, 0 deletions
diff --git a/dom/html/HTMLDetailsElement.h b/dom/html/HTMLDetailsElement.h
new file mode 100644
index 0000000000..d395910e41
--- /dev/null
+++ b/dom/html/HTMLDetailsElement.h
@@ -0,0 +1,65 @@
+/* -*- Mode: C++; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* vim: set ts=8 sts=2 et sw=2 tw=80: */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+#ifndef mozilla_dom_HTMLDetailsElement_h
+#define mozilla_dom_HTMLDetailsElement_h
+
+#include "mozilla/AsyncEventDispatcher.h"
+#include "mozilla/Attributes.h"
+#include "nsGenericHTMLElement.h"
+
+namespace mozilla::dom {
+
+class HTMLSummaryElement;
+
+// HTMLDetailsElement implements the <details> tag, which is used as a
+// disclosure widget from which the user can obtain additional information or
+// controls. Please see the spec for more information.
+// https://html.spec.whatwg.org/multipage/forms.html#the-details-element
+//
+class HTMLDetailsElement final : public nsGenericHTMLElement {
+ public:
+ using NodeInfo = mozilla::dom::NodeInfo;
+
+ explicit HTMLDetailsElement(already_AddRefed<NodeInfo>&& aNodeInfo);
+
+ NS_IMPL_FROMNODE_HTML_WITH_TAG(HTMLDetailsElement, details)
+
+ HTMLSummaryElement* GetFirstSummary() const;
+
+ nsresult Clone(NodeInfo* aNodeInfo, nsINode** aResult) const override;
+
+ void AfterSetAttr(int32_t aNameSpaceID, nsAtom* aName,
+ const nsAttrValue* aValue, const nsAttrValue* aOldValue,
+ nsIPrincipal* aMaybeScriptedPrincipal,
+ bool aNotify) override;
+
+ bool IsInteractiveHTMLContent() const override { return true; }
+
+ // HTMLDetailsElement WebIDL
+ bool Open() const { return GetBoolAttr(nsGkAtoms::open); }
+
+ void SetOpen(bool aOpen, ErrorResult& aError) {
+ SetHTMLBoolAttr(nsGkAtoms::open, aOpen, aError);
+ }
+
+ void ToggleOpen() { SetOpen(!Open(), IgnoreErrors()); }
+
+ virtual void AsyncEventRunning(AsyncEventDispatcher* aEvent) override;
+
+ protected:
+ virtual ~HTMLDetailsElement();
+ void SetupShadowTree();
+
+ JSObject* WrapNode(JSContext* aCx,
+ JS::Handle<JSObject*> aGivenProto) override;
+
+ RefPtr<AsyncEventDispatcher> mToggleEventDispatcher;
+};
+
+} // namespace mozilla::dom
+
+#endif /* mozilla_dom_HTMLDetailsElement_h */