summaryrefslogtreecommitdiffstats
path: root/dom/html/HTMLElement.h
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /dom/html/HTMLElement.h
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/html/HTMLElement.h')
-rw-r--r--dom/html/HTMLElement.h82
1 files changed, 82 insertions, 0 deletions
diff --git a/dom/html/HTMLElement.h b/dom/html/HTMLElement.h
new file mode 100644
index 0000000000..6943d46b6d
--- /dev/null
+++ b/dom/html/HTMLElement.h
@@ -0,0 +1,82 @@
+/* -*- Mode: C++; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* vim: set ts=8 sts=2 et sw=2 tw=80: */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+#ifndef mozilla_dom_HTMLElement_h
+#define mozilla_dom_HTMLElement_h
+
+#include "nsGenericHTMLElement.h"
+
+namespace mozilla::dom {
+
+class HTMLElement final : public nsGenericHTMLFormElement {
+ public:
+ explicit HTMLElement(already_AddRefed<mozilla::dom::NodeInfo>&& aNodeInfo);
+
+ // nsISupports
+ NS_DECL_ISUPPORTS_INHERITED
+ NS_DECL_CYCLE_COLLECTION_CLASS_INHERITED(HTMLElement,
+ nsGenericHTMLFormElement)
+
+ // EventTarget
+ void GetEventTargetParent(EventChainPreVisitor& aVisitor) override;
+
+ // nsINode
+ nsresult Clone(dom::NodeInfo*, nsINode** aResult) const override;
+ nsINode* GetScopeChainParent() const override;
+
+ // nsIContent
+ nsresult BindToTree(BindContext&, nsINode& aParent) override;
+ void UnbindFromTree(bool aNullParent = true) override;
+
+ // Element
+ void SetCustomElementDefinition(
+ CustomElementDefinition* aDefinition) override;
+ bool IsLabelable() const override { return IsFormAssociatedElement(); }
+
+ // nsGenericHTMLElement
+ // https://html.spec.whatwg.org/multipage/custom-elements.html#dom-attachinternals
+ already_AddRefed<mozilla::dom::ElementInternals> AttachInternals(
+ ErrorResult& aRv) override;
+ bool IsDisabledForEvents(WidgetEvent* aEvent) override;
+
+ // nsGenericHTMLFormElement
+ bool IsFormAssociatedElement() const override;
+ void AfterClearForm(bool aUnbindOrDelete) override;
+ void FieldSetDisabledChanged(bool aNotify) override;
+
+ void UpdateFormOwner();
+
+ protected:
+ virtual ~HTMLElement() = default;
+
+ JSObject* WrapNode(JSContext* aCx,
+ JS::Handle<JSObject*> aGivenProto) override;
+
+ // Element
+ void AfterSetAttr(int32_t aNameSpaceID, nsAtom* aName,
+ const nsAttrValue* aValue, const nsAttrValue* aOldValue,
+ nsIPrincipal* aMaybeScriptedPrincipal,
+ bool aNotify) override;
+ ElementState IntrinsicState() const override;
+
+ // nsGenericHTMLFormElement
+ void SetFormInternal(HTMLFormElement* aForm, bool aBindToTree) override;
+ HTMLFormElement* GetFormInternal() const override;
+ void SetFieldSetInternal(HTMLFieldSetElement* aFieldset) override;
+ HTMLFieldSetElement* GetFieldSetInternal() const override;
+ bool CanBeDisabled() const override;
+ bool DoesReadOnlyApply() const override;
+ void UpdateDisabledState(bool aNotify) override;
+ void UpdateFormOwner(bool aBindToTree, Element* aFormIdElement) override;
+
+ void UpdateBarredFromConstraintValidation();
+
+ ElementInternals* GetElementInternals() const;
+};
+
+} // namespace mozilla::dom
+
+#endif // mozilla_dom_HTMLElement_h