summaryrefslogtreecommitdiffstats
path: root/dom/html/HTMLSlotElement.h
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /dom/html/HTMLSlotElement.h
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/html/HTMLSlotElement.h')
-rw-r--r--dom/html/HTMLSlotElement.h88
1 files changed, 88 insertions, 0 deletions
diff --git a/dom/html/HTMLSlotElement.h b/dom/html/HTMLSlotElement.h
new file mode 100644
index 0000000000..fa12f0df26
--- /dev/null
+++ b/dom/html/HTMLSlotElement.h
@@ -0,0 +1,88 @@
+/* -*- Mode: C++; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* vim: set ts=8 sts=2 et sw=2 tw=80: */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+#ifndef mozilla_dom_HTMLSlotElement_h
+#define mozilla_dom_HTMLSlotElement_h
+
+#include "nsGenericHTMLElement.h"
+#include "nsTArray.h"
+#include "mozilla/dom/HTMLSlotElementBinding.h"
+
+namespace mozilla::dom {
+
+class HTMLSlotElement final : public nsGenericHTMLElement {
+ public:
+ explicit HTMLSlotElement(
+ already_AddRefed<mozilla::dom::NodeInfo>&& aNodeInfo);
+ NS_IMPL_FROMNODE_HTML_WITH_TAG(HTMLSlotElement, slot)
+
+ NS_DECL_ISUPPORTS_INHERITED
+ NS_DECL_CYCLE_COLLECTION_CLASS_INHERITED(HTMLSlotElement,
+ nsGenericHTMLElement)
+ nsresult Clone(dom::NodeInfo*, nsINode** aResult) const override;
+
+ // nsIContent
+ nsresult BindToTree(BindContext&, nsINode& aParent) override;
+ void UnbindFromTree(bool aNullParent) override;
+
+ void BeforeSetAttr(int32_t aNameSpaceID, nsAtom* aName,
+ const nsAttrValue* aValue, bool aNotify) override;
+ void AfterSetAttr(int32_t aNameSpaceID, nsAtom* aName,
+ const nsAttrValue* aValue, const nsAttrValue* aOldValue,
+ nsIPrincipal* aSubjectPrincipal, bool aNotify) override;
+
+ // WebIDL
+ void SetName(const nsAString& aName, ErrorResult& aRv) {
+ SetHTMLAttr(nsGkAtoms::name, aName, aRv);
+ }
+
+ void GetName(nsAString& aName) { GetHTMLAttr(nsGkAtoms::name, aName); }
+
+ void AssignedNodes(const AssignedNodesOptions& aOptions,
+ nsTArray<RefPtr<nsINode>>& aNodes);
+
+ void AssignedElements(const AssignedNodesOptions& aOptions,
+ nsTArray<RefPtr<Element>>& aNodes);
+
+ void Assign(const Sequence<OwningElementOrText>& aNodes);
+
+ // Helper methods
+ const nsTArray<RefPtr<nsINode>>& AssignedNodes() const;
+ const nsTArray<nsINode*>& ManuallyAssignedNodes() const;
+ void InsertAssignedNode(uint32_t aIndex, nsIContent&);
+ void AppendAssignedNode(nsIContent&);
+ void RemoveAssignedNode(nsIContent&);
+ void ClearAssignedNodes();
+
+ void EnqueueSlotChangeEvent();
+ void RemovedFromSignalSlotList() {
+ MOZ_ASSERT(mInSignalSlotList);
+ mInSignalSlotList = false;
+ }
+
+ void FireSlotChangeEvent();
+
+ void RemoveManuallyAssignedNode(nsIContent&);
+
+ protected:
+ virtual ~HTMLSlotElement();
+ JSObject* WrapNode(JSContext* aCx, JS::Handle<JSObject*> aGivenProto) final;
+
+ nsTArray<RefPtr<nsINode>> mAssignedNodes;
+ nsTArray<nsINode*> mManuallyAssignedNodes;
+
+ // Whether we're in the signal slot list of our unit of related similar-origin
+ // browsing contexts.
+ //
+ // https://dom.spec.whatwg.org/#signal-slot-list
+ bool mInSignalSlotList = false;
+
+ bool mInManualShadowRoot = false;
+};
+
+} // namespace mozilla::dom
+
+#endif // mozilla_dom_HTMLSlotElement_h