summaryrefslogtreecommitdiffstats
path: root/dom/webgpu/tests/cts/checkout/tsconfig.json
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /dom/webgpu/tests/cts/checkout/tsconfig.json
parentInitial commit. (diff)
downloadfirefox-esr-upstream.tar.xz
firefox-esr-upstream.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webgpu/tests/cts/checkout/tsconfig.json')
-rw-r--r--dom/webgpu/tests/cts/checkout/tsconfig.json49
1 files changed, 49 insertions, 0 deletions
diff --git a/dom/webgpu/tests/cts/checkout/tsconfig.json b/dom/webgpu/tests/cts/checkout/tsconfig.json
new file mode 100644
index 0000000000..2b60900598
--- /dev/null
+++ b/dom/webgpu/tests/cts/checkout/tsconfig.json
@@ -0,0 +1,49 @@
+{
+ "extends": "./node_modules/gts/tsconfig-google.json",
+ "compilerOptions": {
+ "lib": ["dom", "es2019"],
+ "module": "esnext",
+ /* Output options */
+ "noEmit": true,
+ /* Strict type-checking options */
+ "allowJs": true,
+ "strict": true,
+ /* tsc lint options */
+ "noImplicitReturns": true,
+ /* These should be caught by eslint instead */
+ "noFallthroughCasesInSwitch": false,
+ "noUnusedLocals": false,
+ "allowUnreachableCode": true,
+ /* Module Options */
+ "moduleResolution": "node",
+ "esModuleInterop": false,
+ "skipLibCheck": true,
+ },
+ "include": [
+ "src/**/*.ts",
+ "src/external/**/*.js",
+ ],
+ "typedocOptions": {
+ "entryPointStrategy": "expand",
+ "entryPoints": [
+ "src/common/framework/",
+ "src/common/util/",
+ "src/webgpu/",
+ ],
+ "exclude": [
+ "**/*.spec.ts",
+ "**/*.html.ts",
+ "src/*/listing.ts",
+ "src/webgpu/util/device_pool.ts",
+ ],
+ "excludeInternal": true,
+ "excludeProtected": true,
+ "excludePrivate": true,
+ "validation": {
+ "invalidLink": true,
+ "notExported": false,
+ },
+ "readme": "./docs/helper_index.txt",
+ "out": "docs/tsdoc/"
+ }
+}