summaryrefslogtreecommitdiffstats
path: root/dom/webidl/DOMTokenList.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /dom/webidl/DOMTokenList.webidl
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webidl/DOMTokenList.webidl')
-rw-r--r--dom/webidl/DOMTokenList.webidl34
1 files changed, 34 insertions, 0 deletions
diff --git a/dom/webidl/DOMTokenList.webidl b/dom/webidl/DOMTokenList.webidl
new file mode 100644
index 0000000000..c048b2228c
--- /dev/null
+++ b/dom/webidl/DOMTokenList.webidl
@@ -0,0 +1,34 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://dom.spec.whatwg.org/#interface-domtokenlist
+ *
+ * Copyright © 2012 W3C® (MIT, ERCIM, Keio), All Rights Reserved. W3C
+ * liability, trademark and document use rules apply.
+ */
+
+[Exposed=Window]
+interface DOMTokenList {
+ [Pure]
+ readonly attribute unsigned long length;
+ [Pure]
+ getter DOMString? item(unsigned long index);
+ [Pure]
+ boolean contains(DOMString token);
+ [CEReactions, Throws]
+ undefined add(DOMString... tokens);
+ [CEReactions, Throws]
+ undefined remove(DOMString... tokens);
+ [CEReactions, Throws]
+ boolean replace(DOMString token, DOMString newToken);
+ [CEReactions, Throws]
+ boolean toggle(DOMString token, optional boolean force);
+ [Throws]
+ boolean supports(DOMString token);
+ [CEReactions, SetterThrows, Pure]
+ stringifier attribute DOMString value;
+ iterable<DOMString?>;
+};