summaryrefslogtreecommitdiffstats
path: root/layout/reftests/bugs/712849-1.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /layout/reftests/bugs/712849-1.html
parentInitial commit. (diff)
downloadfirefox-esr-upstream.tar.xz
firefox-esr-upstream.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'layout/reftests/bugs/712849-1.html')
-rw-r--r--layout/reftests/bugs/712849-1.html39
1 files changed, 39 insertions, 0 deletions
diff --git a/layout/reftests/bugs/712849-1.html b/layout/reftests/bugs/712849-1.html
new file mode 100644
index 0000000000..83b4c43405
--- /dev/null
+++ b/layout/reftests/bugs/712849-1.html
@@ -0,0 +1,39 @@
+<!DOCTYPE html>
+<html><head>
+<meta http-equiv="content-type" content="text/html; charset=UTF-8">
+ <title>testcase</title>
+<style>
+.tt {
+ border-collapse: collapse;
+}
+.nix {
+ display: none;
+}
+.ref {
+ border: solid 3px darkred;
+}
+
+td {
+ width: 20px;
+ height: 20px;
+}
+
+</style>
+<script>
+
+function test ()
+{
+ document.getElementById ("2").className = "nix";
+ document.getElementById ("3").className = "ref";
+}
+</script>
+</head>
+<body onload="test()">
+ <table class="tt">
+ <tr id="1"><td >&nbsp;</td></tr>
+ <tr id="2"><td >&nbsp;</td></tr>
+ <tr id="3"><td >&nbsp;</td></tr>
+ <tr><td>&nbsp;</td></tr>
+ </table>
+</body>
+</html>