summaryrefslogtreecommitdiffstats
path: root/python/mozperftest/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /python/mozperftest/setup.py
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'python/mozperftest/setup.py')
-rw-r--r--python/mozperftest/setup.py37
1 files changed, 37 insertions, 0 deletions
diff --git a/python/mozperftest/setup.py b/python/mozperftest/setup.py
new file mode 100644
index 0000000000..75ebab9305
--- /dev/null
+++ b/python/mozperftest/setup.py
@@ -0,0 +1,37 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this file,
+# You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import setup
+
+PACKAGE_NAME = "mozperftest"
+PACKAGE_VERSION = "0.2"
+
+deps = [
+ "regex",
+ "jsonschema",
+ "attr",
+ "mozlog >= 6.0",
+ "mozdevice >= 4.0.0",
+ "mozproxy",
+ "mozinfo",
+ "mozfile",
+ "mozperftest-tools",
+]
+
+setup(
+ name=PACKAGE_NAME,
+ version=PACKAGE_VERSION,
+ description="Mozilla's mach perftest command",
+ classifiers=["Programming Language :: Python :: 3.6"],
+ # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+ keywords="",
+ author="Mozilla Performance Test Engineering Team",
+ author_email="tools@lists.mozilla.org",
+ url="https://hg.mozilla.org/mozilla-central/file/tip/python/mozperftest",
+ license="MPL",
+ packages=["mozperftest"],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=deps,
+)