summaryrefslogtreecommitdiffstats
path: root/security/nss/gtests/common/gtest.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /security/nss/gtests/common/gtest.mk
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'security/nss/gtests/common/gtest.mk')
-rw-r--r--security/nss/gtests/common/gtest.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/security/nss/gtests/common/gtest.mk b/security/nss/gtests/common/gtest.mk
new file mode 100644
index 0000000000..ecb324e670
--- /dev/null
+++ b/security/nss/gtests/common/gtest.mk
@@ -0,0 +1,36 @@
+#! gmake
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include $(CORE_DEPTH)/cmd/platlibs.mk
+
+MKPROG = $(CCC)
+MKSHLIB = $(CCC) $(DSO_LDOPTS) $(DARWIN_SDK_SHLIBFLAGS)
+
+# gtests pick up errors with signed/unsigned comparisons on some platforms
+# even though we disabled -Wsign-compare.
+# This catches that by enabling the warning.
+# Only add -Wsign-compare if -Werror is enabled, lest we add it on the wrong
+# platform.
+ifeq (-Werror,$(filter -Werror -Wsign-compare,$(WARNING_CFLAGS)))
+WARNING_CFLAGS += -Wsign-compare
+endif
+WARNING_CFLAGS := $(filter-out -w44018,$(WARNING_CFLAGS))
+
+ifeq (WINNT,$(OS_ARCH))
+ # -EHsc because gtest has exception handlers
+ OS_CFLAGS += -EHsc -nologo
+ # http://www.suodenjoki.dk/us/archive/2010/min-max.htm
+ OS_CFLAGS += -DNOMINMAX
+
+ # Linking to winsock to get htonl
+ OS_LIBS += Ws2_32.lib
+
+ # On windows, we need to create the parent directory
+ # Needed because we include files from a subdirectory
+ MAKE_OBJDIR = $(INSTALL) -D $(dir $@)
+else
+ CXXFLAGS += -std=c++0x
+endif