summaryrefslogtreecommitdiffstats
path: root/testing/mochitest/mochitest-e10s-utils.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /testing/mochitest/mochitest-e10s-utils.js
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/mochitest/mochitest-e10s-utils.js')
-rw-r--r--testing/mochitest/mochitest-e10s-utils.js18
1 files changed, 18 insertions, 0 deletions
diff --git a/testing/mochitest/mochitest-e10s-utils.js b/testing/mochitest/mochitest-e10s-utils.js
new file mode 100644
index 0000000000..09046794bb
--- /dev/null
+++ b/testing/mochitest/mochitest-e10s-utils.js
@@ -0,0 +1,18 @@
+// Utilities for running tests in an e10s environment.
+
+function e10s_init() {
+ // Listen for an 'oop-browser-crashed' event and log it so people analysing
+ // test logs have a clue about what is going on.
+ window.addEventListener(
+ "oop-browser-crashed",
+ event => {
+ let uri = event.target.currentURI;
+ console.error(
+ "remote browser crashed while on " +
+ (uri ? uri.spec : "<unknown>") +
+ "\n"
+ );
+ },
+ true
+ );
+}