summaryrefslogtreecommitdiffstats
path: root/testing/mozbase/moznetwork/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /testing/mozbase/moznetwork/setup.py
parentInitial commit. (diff)
downloadfirefox-esr-upstream.tar.xz
firefox-esr-upstream.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/mozbase/moznetwork/setup.py')
-rw-r--r--testing/mozbase/moznetwork/setup.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/mozbase/moznetwork/setup.py b/testing/mozbase/moznetwork/setup.py
new file mode 100644
index 0000000000..84940e3de0
--- /dev/null
+++ b/testing/mozbase/moznetwork/setup.py
@@ -0,0 +1,36 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this file,
+# You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import setup
+
+PACKAGE_VERSION = "1.1.0"
+
+deps = [
+ "mozinfo",
+ "mozlog >= 6.0",
+]
+
+setup(
+ name="moznetwork",
+ version=PACKAGE_VERSION,
+ description="Library of network utilities for use in Mozilla testing",
+ long_description="see https://firefox-source-docs.mozilla.org/mozbase/index.html",
+ classifiers=[
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.5",
+ "Development Status :: 5 - Production/Stable",
+ ],
+ # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+ keywords="mozilla",
+ author="Mozilla Automation and Tools team",
+ author_email="tools@lists.mozilla.org",
+ url="https://wiki.mozilla.org/Auto-tools/Projects/Mozbase",
+ license="MPL",
+ packages=["moznetwork"],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=deps,
+ entry_points={"console_scripts": ["moznetwork = moznetwork:cli"]},
+)