summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/imagebitmap-renderingcontext/toBlob-origin-clean-offscreen.sub.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /testing/web-platform/tests/imagebitmap-renderingcontext/toBlob-origin-clean-offscreen.sub.html
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/imagebitmap-renderingcontext/toBlob-origin-clean-offscreen.sub.html')
-rw-r--r--testing/web-platform/tests/imagebitmap-renderingcontext/toBlob-origin-clean-offscreen.sub.html27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/web-platform/tests/imagebitmap-renderingcontext/toBlob-origin-clean-offscreen.sub.html b/testing/web-platform/tests/imagebitmap-renderingcontext/toBlob-origin-clean-offscreen.sub.html
new file mode 100644
index 0000000000..0b00f92a95
--- /dev/null
+++ b/testing/web-platform/tests/imagebitmap-renderingcontext/toBlob-origin-clean-offscreen.sub.html
@@ -0,0 +1,27 @@
+<!DOCTYPE html>
+<meta charset=utf-8>
+<title>convertToBlob, OffscreenCanvas: origin-clean flag</title>
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<link rel="help" href="https://html.spec.whatwg.org/multipage/scripting.html#the-imagebitmap-rendering-context">
+<script>
+const crossOriginImageUrl = "http://{{domains[www1]}}:{{ports[http][0]}}/images/red.png";
+
+async_test(t => {
+ var img = new Image();
+ // Use a cross-origin URL.
+ img.src = crossOriginImageUrl;
+
+ img.onload = t.step_func(e => {
+ createImageBitmap(img, 0, 0, img.width, img.height)
+ .then(t.step_func(bitmap => {
+ var canvasBitmap = new OffscreenCanvas(img.width,img.height);
+ var contextBitmap = canvasBitmap.getContext("bitmaprenderer");
+ contextBitmap.transferFromImageBitmap(bitmap);
+ promise_rejects_dom(t, 'SecurityError',
+ canvasBitmap.convertToBlob(),
+ "convertToBlob on a tainted OffscreenCanvas has to throw").then(t.step_func_done());
+ }));
+ });
+}, "Test that call convertToBlob on a tainted OffscreenCanvas throws exception");
+</script>