summaryrefslogtreecommitdiffstats
path: root/third_party/rust/alsa/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/alsa/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/alsa/Cargo.toml')
-rw-r--r--third_party/rust/alsa/Cargo.toml57
1 files changed, 57 insertions, 0 deletions
diff --git a/third_party/rust/alsa/Cargo.toml b/third_party/rust/alsa/Cargo.toml
new file mode 100644
index 0000000000..15f45319b1
--- /dev/null
+++ b/third_party/rust/alsa/Cargo.toml
@@ -0,0 +1,57 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "alsa"
+version = "0.7.0"
+authors = ["David Henningsson <coding@diwic.se>"]
+include = [
+ "README.md",
+ "LICENSE-*",
+ "Cargo.toml",
+ "src/",
+]
+description = "Thin but safe wrappers for ALSA (Linux sound API)"
+documentation = "http://docs.rs/alsa"
+readme = "README.md"
+keywords = [
+ "ALSA",
+ "audio",
+ "sound",
+]
+categories = [
+ "multimedia::audio",
+ "api-bindings",
+]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/diwic/alsa-rs"
+resolver = "2"
+
+[dependencies.alsa-sys]
+version = "0.3.1"
+
+[dependencies.bitflags]
+version = "1.3.2"
+
+[dependencies.libc]
+version = "0.2"
+
+[dependencies.nix]
+version = "^0.24"
+features = ["ioctl"]
+default-features = false
+
+[badges.is-it-maintained-issue-resolution]
+repository = "diwic/alsa-rs"
+
+[badges.is-it-maintained-open-issues]
+repository = "diwic/alsa-rs"