summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cc/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/cc/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-upstream.tar.xz
firefox-esr-upstream.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/cc/Cargo.toml')
-rw-r--r--third_party/rust/cc/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/third_party/rust/cc/Cargo.toml b/third_party/rust/cc/Cargo.toml
new file mode 100644
index 0000000000..ad0ec21385
--- /dev/null
+++ b/third_party/rust/cc/Cargo.toml
@@ -0,0 +1,33 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "cc"
+version = "1.0.73"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+exclude = ["/.github", "/.travis.yml", "/appveyor.yml"]
+description = "A build-time dependency for Cargo build scripts to assist in invoking the native\nC compiler to compile native C code into a static archive to be linked into Rust\ncode.\n"
+homepage = "https://github.com/alexcrichton/cc-rs"
+documentation = "https://docs.rs/cc"
+readme = "README.md"
+keywords = ["build-dependencies"]
+categories = ["development-tools::build-utils"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/alexcrichton/cc-rs"
+[dependencies.jobserver]
+version = "0.1.16"
+optional = true
+[dev-dependencies.tempfile]
+version = "3"
+
+[features]
+parallel = ["jobserver"]