summaryrefslogtreecommitdiffstats
path: root/third_party/rust/core-graphics/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/core-graphics/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/core-graphics/Cargo.toml')
-rw-r--r--third_party/rust/core-graphics/Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/third_party/rust/core-graphics/Cargo.toml b/third_party/rust/core-graphics/Cargo.toml
new file mode 100644
index 0000000000..b3871d54f4
--- /dev/null
+++ b/third_party/rust/core-graphics/Cargo.toml
@@ -0,0 +1,41 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "core-graphics"
+version = "0.22.3"
+authors = ["The Servo Project Developers"]
+description = "Bindings to Core Graphics for macOS"
+homepage = "https://github.com/servo/core-graphics-rs"
+license = "MIT / Apache-2.0"
+repository = "https://github.com/servo/core-foundation-rs"
+[package.metadata.docs.rs]
+default-target = "x86_64-apple-darwin"
+[dependencies.bitflags]
+version = "1.0"
+
+[dependencies.core-foundation]
+version = "0.9"
+
+[dependencies.core-graphics-types]
+version = "0.1"
+
+[dependencies.foreign-types]
+version = "0.3.0"
+
+[dependencies.libc]
+version = "0.2"
+
+[features]
+default = []
+elcapitan = []
+highsierra = []