summaryrefslogtreecommitdiffstats
path: root/third_party/rust/debugid/scripts
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/debugid/scripts
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/debugid/scripts')
-rwxr-xr-xthird_party/rust/debugid/scripts/bump-version.sh17
1 files changed, 17 insertions, 0 deletions
diff --git a/third_party/rust/debugid/scripts/bump-version.sh b/third_party/rust/debugid/scripts/bump-version.sh
new file mode 100755
index 0000000000..41e67772d9
--- /dev/null
+++ b/third_party/rust/debugid/scripts/bump-version.sh
@@ -0,0 +1,17 @@
+#!/bin/bash
+set -euo pipefail
+
+if [ "$(uname -s)" != "Linux" ]; then
+ echo "Please use the GitHub Action."
+ exit 1
+fi
+
+SCRIPT_DIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
+cd $SCRIPT_DIR/..
+
+OLD_VERSION="${1}"
+NEW_VERSION="${2}"
+
+echo "Bumping version: ${NEW_VERSION}"
+
+find . -name Cargo.toml -type f -exec sed -i '' -e "s/^version.*/version = \"$NEW_VERSION\"/" {} \;