summaryrefslogtreecommitdiffstats
path: root/third_party/rust/lazy_static/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/lazy_static/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-upstream.tar.xz
firefox-esr-upstream.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/lazy_static/Cargo.toml')
-rw-r--r--third_party/rust/lazy_static/Cargo.toml46
1 files changed, 46 insertions, 0 deletions
diff --git a/third_party/rust/lazy_static/Cargo.toml b/third_party/rust/lazy_static/Cargo.toml
new file mode 100644
index 0000000000..7f930c5e3d
--- /dev/null
+++ b/third_party/rust/lazy_static/Cargo.toml
@@ -0,0 +1,46 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "lazy_static"
+version = "1.4.0"
+authors = ["Marvin Löbel <loebel.marvin@gmail.com>"]
+exclude = ["/.travis.yml", "/appveyor.yml"]
+description = "A macro for declaring lazily evaluated statics in Rust."
+documentation = "https://docs.rs/lazy_static"
+readme = "README.md"
+keywords = ["macro", "lazy", "static"]
+categories = ["no-std", "rust-patterns", "memory-management"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rust-lang-nursery/lazy-static.rs"
+[dependencies.spin]
+version = "0.5.0"
+optional = true
+[dev-dependencies.doc-comment]
+version = "0.3.1"
+
+[features]
+spin_no_std = ["spin"]
+[badges.appveyor]
+repository = "rust-lang-nursery/lazy-static.rs"
+
+[badges.is-it-maintained-issue-resolution]
+repository = "rust-lang-nursery/lazy-static.rs"
+
+[badges.is-it-maintained-open-issues]
+repository = "rust-lang-nursery/lazy-static.rs"
+
+[badges.maintenance]
+status = "passively-maintained"
+
+[badges.travis-ci]
+repository = "rust-lang-nursery/lazy-static.rs"