summaryrefslogtreecommitdiffstats
path: root/third_party/rust/mach/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/mach/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-upstream.tar.xz
firefox-esr-upstream.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/mach/Cargo.toml')
-rw-r--r--third_party/rust/mach/Cargo.toml46
1 files changed, 46 insertions, 0 deletions
diff --git a/third_party/rust/mach/Cargo.toml b/third_party/rust/mach/Cargo.toml
new file mode 100644
index 0000000000..ea6d375c2c
--- /dev/null
+++ b/third_party/rust/mach/Cargo.toml
@@ -0,0 +1,46 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2015"
+name = "mach"
+version = "0.3.2"
+authors = ["Nick Fitzgerald <fitzgen@gmail.com>", "David Cuddeback <david.cuddeback@gmail.com>", "Gonzalo Brito Gadeschi <gonzalobg88@gmail.com>"]
+description = "A Rust interface to the user-space API of the Mach 3.0 kernel that underlies OSX."
+readme = "README.md"
+keywords = ["kernel", "macos", "darwin"]
+categories = ["api-bindings", "external-ffi-bindings", "no-std", "os"]
+license = "BSD-2-Clause"
+repository = "https://github.com/fitzgen/mach"
+
+[features]
+default = []
+deprecated = []
+rustc-dep-of-std = ["rustc-std-workspace-core", "libc/rustc-dep-of-std"]
+[target."cfg(any(target_os = \"macos\", target_os = \"ios\"))".dependencies.libc]
+version = "0.2"
+default-features = false
+
+[target."cfg(any(target_os = \"macos\", target_os = \"ios\"))".dependencies.rustc-std-workspace-core]
+version = "1.0.0"
+optional = true
+[badges.is-it-maintained-issue-resolution]
+repository = "fitzgen/mach"
+
+[badges.is-it-maintained-open-issues]
+repository = "fitzgen/mach"
+
+[badges.maintenance]
+status = "passively-maintained"
+
+[badges.travis-ci]
+repository = "fitzgen/mach"