summaryrefslogtreecommitdiffstats
path: root/third_party/rust/minidump-common/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/minidump-common/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-upstream.tar.xz
firefox-esr-upstream.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/minidump-common/Cargo.toml')
-rw-r--r--third_party/rust/minidump-common/Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/third_party/rust/minidump-common/Cargo.toml b/third_party/rust/minidump-common/Cargo.toml
new file mode 100644
index 0000000000..691a9b9b3e
--- /dev/null
+++ b/third_party/rust/minidump-common/Cargo.toml
@@ -0,0 +1,51 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "minidump-common"
+version = "0.15.2"
+authors = ["Ted Mielczarek <ted@mielczarek.org>"]
+description = "Some common types for working with minidump files."
+homepage = "https://github.com/rust-minidump/rust-minidump"
+readme = "README.md"
+license = "MIT"
+repository = "https://github.com/rust-minidump/rust-minidump"
+
+[dependencies.arbitrary]
+version = "1"
+features = ["derive"]
+optional = true
+
+[dependencies.bitflags]
+version = "1.3.2"
+
+[dependencies.debugid]
+version = "0.8.0"
+
+[dependencies.enum-primitive-derive]
+version = "0.2.2"
+
+[dependencies.num-traits]
+version = "0.2"
+
+[dependencies.range-map]
+version = "0.2"
+
+[dependencies.scroll]
+version = "0.11.0"
+features = ["derive"]
+
+[dependencies.smart-default]
+version = "0.6.0"
+
+[badges.travis-ci]
+repository = "rust-minidump/rust-minidump"